After IGEL UMS upgrade I keep getting a permission error when adding new devices to the UMS

We upgraded to UMS 6.04.120 (Build number 46110) from UMS 5. After the upgrade I keep getting a permission error when adding new devices to the UMS. I was able to add devices before the upgrade. We tried removing the groups that I am in and readding them. We also tried giving my group administrator rights. Is there anything else that we should try/look into?

Learn more, read the entire thread inside the IGEL Community o Slack

1.Do you checked already administrator permissions like scanning for devices:

2. Maybe you can check that solution too. I know you have an older ums build, but maybe that helps for your problem too:

If that not helps, it would good to know, at which steps the error occurred. For example the error occurred when you want to scanning for a device, or if you add the devce to the main folder or if you add the device to the sub folder XYZ.

I am able to scan for devices. The error will occur when I click the “ok” button to add the device into the UMS. Since we have multiple sites using the same UMS I only have access and can only see my site. I tried the main “devices” folder with no permissions set. The next folder (from there we have split off to region (NA, EU etc) then into sites) with no permissions set for my account or group. For my site (and all of the folders in my site) I don’t have any explicit deny rules for my account and groups. I have allow checked for all permissions for my site.

My groups do have “Scan for devices” checked

Can you please check all folders to the way to your folder, where you want to move the device to? With this step I ́ve attached for you. So the main folder “devices” and the following folders are really important to show. And “not set” means for my understanding in this case , that you therefore do not have the permission and therefore cannot interact with it. You could also test this again if you set the rights “not set”, which you need to “allowed”, if you then no longer receive an error message.

We looked into the problem a little bit more today. We noticed that a setting for automatically adding devices into the UMS was enabled. We may think that this might be part of our problem. We won’t know for sure until Monday when our head admin gets back.

The automatic addition of IGEL clients is usually not responsible for this. We also use it ourselves to save as much time as possible, which is very easy with IGEL. But otherwise we can wait until the head admin is there and has a look, otherwise the community and support will be happy to help. 🙂

Hi Leon, our IGEL admin disabled the automatic adding feature and gave my group move permissions at the root directory. After that I’m able to add devices again. Thank you for your help!

Continue reading and comment on the thread ‘After IGEL UMS upgrade I keep getting a permission error when adding new devices to the UMS’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base

Ask a question or comment on the above message thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!

Popular Message Threads

Categories & Tags: