After migrating IGEL OS devices from one UMS to another Citrix logins receive root certificate error


Hello everyone! I am in the process of migrating devices from one UMS to another. Once the device is added to the new server I go to log into a citrix and I get the root certificate error. This looks to only be new devices being added. My test device is on the same UMS with the same policies applied and works just fine.


Hello Brad, I would have a look on the files section of your old server and check if you added a File for your RootCA:

kb.igel.com/endpointmgmt/en/registering-a-file-on-the-ums-server-22460014.html


I have uploaded the intermediate and root cert but that seems to cause authentication issues once i have done that. The other devices are working on the same UMS w/o any cert file working. So I have 3 Devices working and 3 not working

I am thinking that it has something to do with the time zone because the devices that are not working are on central time and the devices working are on eastern

I have uploaded the root, intermediate and wildcard cert as common and still got the error. I tried uploading all three again as SSL and still seeing the error message. I will go back to the fact that hte devices not working are central time. I have applied to the policy the NTP time server. I can see at the device level that the policy is applied but it looks like the still have the ability to modify the time zone and location.

I have uploaded the root, intermediate and wildcard cert as common and still got the error. I tried uploading all three again as SSL and still seeing the error message. I will go back to the fact that hte devices not working are central time. I have applied to the policy the NTP time server. I can see at the device level that the policy is applied but it looks like the still have the ability to modify the time zone and location.


Just in case, when going to Terminal (Accessories, Terminal, + in a profile), loging in as root, going to:

ll /wfs/ca-certs

are you certs there? If you do

cat yourcacert.crt

do they start with begincerts or with hieroglyphs?

Continue reading and comment on the thread ‘After migrating IGEL OS devices from one UMS to another Citrix logins receive root certificate error’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base



Ask a question or comment on the above messasge thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!


Popular Message Threads


Categories & Tags: