After upgrading from IGEL OS 11.3 to 11.4 can’t connect to ICG?

Anyone have any thoughts on this? I have gone through updating from multiple versions of 11.3 firmware to 11.4 and can recreate this issue 100% of the time. After upgrading, they will no longer attempt to connect to ICG. If I attach them to our internal network it connects to UMS. I am then able to remove the Profiles, reboot, and re-add the profiles. It will then connect to the ICG just fine.

Learn more, read the entire thread inside the IGEL Community o Slack

I might have an not realized it with mine (at home), since this is the only remote thin client I upgraded to 11.04.100 the other day. Fortunately, I have a shortcut in the start menu to run ICG setup and I know the URL and pass code. But, I’m glad you mentioned this before I went ahead and started deploying. Maybe there needs to be a custom action to re-run the ICG setup command?

That doesn’t help with mine.

Tried doing that, but no change.

Running the ICG setup wizard doesn’t work for you? I have another device here that I believe is running 11.03. Its been in a box for awhile and likely not connected to ICG, but I’ll get it setup soon and will see if I can reproduce it too.

Correct. I’ve been able to reproduce on two different devices

I have rolled one of them back to two different 11.03 versions and re-uograded with the same results

@member does journalctl show rmagent trying to initialize and generate errors, or are you even seeing that?

I’ll look and report back

I just updated a remote thin client (through ICG) from 11.03.500.01 to and the thin client did not loose it’s config or connectivity to ICG. I’ll test some more devices as time permits

ok. I just got one of my devices back to 11.03.110. I will look through the profiles and see if I can figure out what one(s) may be causing the issue.

@member, just curious are you doing a direct NAT or IP route to the ICG, or is there any SIEM or Load Balancer application in front of it?

ICG is NAT’d

@member I found igelrm_agent trying to connect to our UMS server, but don’t see it trying to connect to the ICG when that fails. I found I do not need to remove/re-add any profiles to get it to work. If I connect it to the internal network, restart network_manager, and then move off the internal network after it has connected to UMS, it will then connect to the ICG.

So from cold boot it won’t connect to ICG unless it see’s UMS first?

correct. After upgrading from (different versions) to 11.04.100. I don’t see it trying to connect to ICG until after connecting to UMS. I am going to test with no profiles getting applied after installing 11.03.110.

Odd, I have done this now multiple times. All of mine connect :thinking_face:

it must be something with one of my profiles. Doing it without any profiles assigned, it works as it should

Now to start adding one profile at a time to see which one is causing it


hmm, this is interesting. It shows connected to ICG, but UMS still has the icon showing it is updating (even after refresh).

Hasn’t been able to report back after the update :thinking_face:

Maybe I should restart the ICG

I’ll try in the morning. Been trying not to work in the evenings.

You and me both..yet here I am 😛

Yeah, I’ll comment, but if I get on my work computer to do something, I’ll get drawn in…lol

so, this morning I looked at journalctl and it was showing a message that it wasn’t able to open a socket or something like that. I rebooted again to see it go through the steps again. Well, it connected that time. So, going to redo it again and see if some additional reboots takes care of the issue.

redoing it, it worked as it should. Going to start adding some profiles in to see if it continues to work properly. Also, I did not restart the ICG this morning as I had planned.

maybe network issue that was resolved?

Usually it’s something blocking or breaking the websocket connection

One thing I did just realize, I am using different profiles than I originally was. After this current test, I will try using the original profiles. The original ones were based on 11.03.110 and the current ones are based on 11.04.100.

hmm, so must be some profile that is based on 11.03.110 that causing the issue. With all the 11.03.110 profiles applied, the issue returned.

so not sure which profile yet, but it makes sense to me now why connecting internally fixes the icg conneciton. Default Directory rules put this into a directory that has profiles based on 11.04.100 in it. So the 11.03.110 profiles are removed and the 11.04.100 profiles are added.

ok, so it seems to be an intermittent issue, which supports what @member mentioned about something blocking/breaking the websocket connection. After reverting and applying all the 11.03.110 profiles to it, then upgrading, everything still works fine. :man-shrugging:

Thanks @member and @member for your help

Wait, so is there a problem? Or, something weird with your setup? I kind of like it that you’re leading the path 🙂

idk, I’ve spent so much time on it and can’t get it to happen again with the devices I have, I’m kind of at a point I can’t do much more. I guess I do have one more device here I haven’t upgraded that I could test with, not to mention the UDPockets I have.

Interesting, back to 11.04.100 devices not connecting to ICG. They have been, but today all of a sudden, will not connect. Looking in journalctl, I can see “WARN: lws_client_handshake: got bad HTTP response ‘401’”. The next line shows “ERROR: Websocket connection error: HS: ws upgrade unauthorized” The next couple lines just shows it failed to connect to ICG

this is both 11.04.100 and 11.04.100rc7

Just went through and updated the OS on the ICG and now it is working. Fingers crossed that was the issue.

I’ve never had to do an OS update on a machine without Internet access. Well, I guess this has port 8443 open, but that’s it. So couldn’t update from the machine directly. That was interesting.

Continue reading and comment on the thread ‘After upgrading from IGEL OS 11.3 to 11.4 can’t connect to ICG?’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base

Ask a question or comment on the above message thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!

Popular Message Threads

Categories & Tags: