After upgrading ICG cert the 4th part of the fingerprint is not working


Hi folks, an odd one. I’m trying to register an iGel on ICG via the ICG Agent Setup. I’ve already done a few but between then and now the ICG cert expired (not the root) and had to be renewed. When connecting with the ICG Agent, I get the usual 3 parts of the fingerprint and they match that of the root certificate but when I put the 4th part it it complains it’s incorrect. Any ideas?


Typo?

Or, check the local time on the device. Even if the certificate is valid and you have inputted the correct fingerprint, the handshake will fail due to time discrepancies.


Good morning Scott, is the cert for the ICG still expired, or did you generate a new endpoint certificate already? If not, can you generate a new one and update the cert on the ICG?


Thanks guys, re typo, I tried several times and look lonnnnng and hard at the sequence, so happy there. Great idea re time, unfortunately time match on both devices. I did generate a new endpoint cert and believe it’s in use and I could not get the existing iGels to reconnect to the ICG until I did so.


That looks correct to me, and I can see the public cert with openssl. If you want to PM me with the fingerprint and a temporary password, I can try to join a test device (already licensed) to your ICG to see if I get the same result.

Continue reading and comment on the thread ‘After upgrading ICG cert the 4th part of the fingerprint is not working’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base



Ask a question or comment on the above messasge thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!


Popular Message Threads


Categories & Tags: