After upgrading to IGEL OS 11.05.100 many users are reporting the devices being totally frozen

I updated our IGELs to version on 3/7/21. Since the update we have many users that have reported the IGEL being totally frozen. We use a VMWare VDI, and the VMWare Horizon dropdown toolbar become inaccessible after the freeze. Rebooting the IGEL is the only workaround. Has anyone else experienced this?

Learn more, read the entire thread inside the IGEL Community o Slack

We also use the Zoom VDI Media Plugin. I see in the product release notes that there is a known issue when “the Zoom VDI Media Plugin makes Horizon Client crash upon connection to the remote desktop in cases when TCSetup is running at the same time.” I’m not sure what TCSetup is, but makes me feel like this is relevant to my issue. However, my users are experiencing the crash well after connecting to the IGEL.

_TCSetup_ is the local IGEL Setup and the effect is that you cannot start your remote desktop session while it (the setup) is running due to a bug in the Zoom VDI virtual channel initialization. This is most likely not your problem (solution in this case would be simply to close the setup).

Which protocol are you using? PCoIP or Blast?

We are using PCoIP protocol. Blast has never worked well for us. There is a delay between clicks/keystrokes and when they appear onscreen.

This delay is a known issue since some time: Blast does not work well with the specific Direct Rendering Infrastructure (DRI2) we are using by default because Citrix ICA is only working with DRI2.

For Blast (with hw acceleration) you need to switch on DRI3 in the IGEL Registry: _x.drivers.use_dri3_

But regarding PCoIP: we have seen a freeze very recently which also included the menubar. It occured on logout of the session.

We found that it was triggered by the extra virtual channel used for serial port and native scanner redirection in certain cases.

Have you configured one of these?

All this extra features are making Horizon Client a delicate thing to handle, I must concede that.

We have seen this issue on 11.4 aswell. We have seen the crashes occur hours after the user has logged in thou.

Same Problem as Jared, aswell on 11.4. with Blast and DRI3 activated.

We tried updating to 11.5 and ran into the same issue

In our case we do not have scanner redirection or serial port or any virtual channels on

Our DRI3 drivers were enabled, but 95% of our userbase was using PCoIP. We also had some problems in our USB redirection profile that may have been causing crashes. Once I made those changes, there have been no reports of crashing.

1. Change Sessions > Horizon Client > Horizon Client Global > Performance > PCoIP image cache to the default of 50MB

2. Sessions > Horizon Client > Horizon Client Global > USB Redirection default rule should be set to ‘deny’

3. disable the following registry key: vmware.view.usb.allowlasthid

4. revert vmware.view.usb.allow-dev-desc-failsafe back to its default of ‘disabled’

5. switch to BLAST protocol

Thanks, I will give it a try.

Continue reading and comment on the thread ‘After upgrading to IGEL OS 11.05.100 many users are reporting the devices being totally frozen’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base

Ask a question or comment on the above message thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!

Popular Message Threads

Categories & Tags: