After upgrading UD2 to IGEL OS 11.05.133 we see multiple errors – “Multiple Active Partitions” / no network / black screen


It is terrible. Yesterday i’ve updated our UD2-LX40 and LX50 from 11.03.500 to 11.04.27 and then to 11.05.133.

Learn more, read the entire thread inside the IGEL Community o Slack

First i updated 10 test devices with no problem. Than i did it with all others.

Now i have multiple devices with different errors!

1. Some devices with error “Multiple Active Partitions”

2. Some with no network. Message LAN connected, LAN disconnected all the time

3. Some with a black screen and a “grub” cursor…

Please help :/

Hi Gero, please open a ticket in parallel, this issue needs to be tracked!

How did you initiated the update?

How many devices are affected?

Do you have physical access to them / PXE in place?

Hi Sebastien,

i’ve initiated the update via UMS.

At the moment i’ve round about 10 devices with problems.

Partitially i’ve physical access to the devices.

Some of them are in our branches so i had to drive with car.


You should try 11.05.138! Most of my problems are solved! I am using a priority list now to test firmware with native IGEL devices and with UD-Pockets because I had different behavior with those in case of webcams.

This is the list that not the customer has to check, but IGEL:

1. Citrix sessions are neatly logged out, so you need a password for a new registration.

2. Screen switching works on my test devices

3. ZOOM works with IGEL UD3 and with UD pocket with USB-Webcam an microphone

4. Connecting or disconnecting USB devices keeps the Citrix session running.

_If the 1st condition ist not fulfilled you can forget the firmware for security reasons!!_

Do you have Other devices in this branch offices that went through the update without issue? Is there a server onsite? I’m thinking of: how to recover this devices…

@member Yes, there are working devices in the branches and there is a Windows server too in every branch.

If you can, you could use the Server as a PXE Server and deploy 11.05.133:

OK. Will try. Thank you.

Are you sure your devices have enough RAM and Flash space for 11.05.133?

And LAN-Messages at my devices have been messages, but without any issues with the real LAN-connection behavior.

I use a feature reduce profile. Actually affected devices has 2 and 4 GB of flash.

Do you have a quick tutorial for Server? I think i have to use the FTP option. But which is the root directory?

Unfortunately the LAN messages are not only messages. Devices are offline.

Would be TFTP in that case.

Could you please check on a similar device if you have a PXE Bootoption in Bios? I’m not sure if this option us available everywhere…

In our main branch we’ve created a recovery usb stick with rufus (preparestick doesnt work). But after boot there is only a message that the installer includes no firmware.

OK, TFTP is activated and root directory is folder with uncompressed igel OS. But test device skips PXE boot.

Which Firmware (ISO) did you used on stick?


Could you please check on a similar device if you have a PXE Bootoption in Bios? I’m not sure if this option us available everywhere…

For the stick i used 11.05.133

On the test device there is a PXE option in BIOS. We have set it to enabled. But it runs throug and does not boot from PXE

How are you doing the PXE and TFTP bootfile options via DHCP? If you’re using another system for DHCP and pointing to it, you just need to select which bootfile you wish to use for UEFI devices.

Default BIOS file name = pxelinux.0

UEFI 32 bit file name = BOOTX32.EFI

UEFI 64 bit file name = BOOTX64.EFI

Uh. OK. DHCP must be configured too. My fault. I have to look…

Can you give me a hint for the USB recovery stick?

Sure, if I would have a first thought, something went wrong during creation. Could you share the settings of the Rufus?

Sure. Screenshot shows the rufus settings and the content of the stick after creation.

Looks good, could you try 11.05.120 instead of 11.05.133?

Same problem with 11.05.120 !

how many ram is on the device you are connecting the stick to?


could you try on a4gb device?

Unfortunately we have only devices with 2GB of RAM…. 😕

do you have a laptop or pc maybe? Just to see if this might the issue?

Update for the problem “Multiple active partitions” and “Grub cursor”:

In BIOS/SCU we have enabled “Dual boot” and after this we entered the Boot manager and choosed “Internal EFI Shell”. In EFI shell startup.nsh is executed and after this the devices boot up!

I will try the USB stick on a PC in a few Minutes.

But maybe you should give the informations about the boot problem to your support so that they can fix this in future versions…

I’ve no ticket created till now because lack of time 😕

Same message/problem with USB stick on a PC with 16GB RAM.

We have now round about 8 devices left with the LAN problem. Message LAN connected/disconnected appears repeatedly every few seconds. Device is offline. Failsafe boot with CRC check and factory reset does not solve it.

Maybe we can fix this with a working USB stick…?

Yes, it should work with the OSC stick you are creating but I don’t get why it isn’t working on your side… I just tried it here, and it worked…

Is there maybe an AV which blocks the Stick creation? Could you try another PC (a non managed one) try there:



and another USB Stick

For Rufus: I’ve found that after selecting “start”, you will get a pop-up box for ISOHybrid mode – I’ve used the “DD image mode” successfully. Are you using that?

USB stick creation succeeded!

We have prepared a fresh Win10 laptop without AV besides Windows Defender and no domain join. On this machine we successfull created the USB stick with prepareusb!

No idea why it doesn’t worked on our domain joined machines with sophos AV….

With the stick we reflashed/installed the clients with LAN disconnecting problem and after this these clients are now working too. Some of them lost her config and we rejoined them in UMS.

@member No, we only tried the ISO mode with rufus. But thank you for the hint!

Continue reading and comment on the thread ‘After upgrading UD2 to IGEL OS 11.05.133 we see multiple errors – “Multiple Active Partitions” / no network / black screen’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base

Ask a question or comment on the above message thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!

Popular Message Threads

Categories & Tags: