Aftrer updating IGEL UMS the “Check for new firmware updates” fails with error “Internal error: java.lang.NullPointException”

Hi! I just made a big update jump on UMS from 5.09.xx to the latest 6.04.100. Now after the update clicking “Check for new firmware updates” I get following error “Internal error: java.lang.NullPointException”

Learn more, read the entire thread inside the IGEL Community o Slack

Hi Jani, just before analyzing the Logs:

• did you restarted the IgelRmGuiserver Service on UMS Server?

• is enough memory (RAM) available when opening the Taskmanager? We changed the allocated RAM:

• is the connectivity check green? Test Server connection: the first field should be green

• Which kind of DB are you using?

Internal DB, I’ve restarted the service and the entire server. Connectivity check gets the green light. Only thing is we have 6GB of memory but there seems to be bunch of it free. I can check if increasing the memory on the server does anything

Thanks for that! Is a Antivirus installed on the UMS Server?

The 8GB memory did no difference. We have F-Secure Server Protection on the server. The server itself is 2012 R2.

I know it sounds wrong but could you disable the AV completely and restart the Service again?

I disabled all the AV services and restarted RMGUIServer service. Still the same java error.

Ok! Let the AV disable and restart the UMS Installation process until the end. Then Optimize Database and retry.

If that doesn‘t work you could check the logs: IGELRemoteManagerrmguiserverlogs should list catalina and other logs.

Just in case:

I just checked our test server which is still running and has no antivirus on the server at all and it’s getting the same error.

Then I would go for the Network / Log check.

Are you using a Proxy or FW in between, please check even if green if are allowed on 80 and 443. Next thing is still the Log check

Yeah I made a support ticket and sent the logs to them actually. Have to check the ports. Nothing should’ve changed though.. but have to double check. Thanks for your time and help. I have to leave in a moment. I’ll wait if the support ticket gets any replies and I’ll check the networks stuff tomorrow with our network team.

That would be great since we changed the URL and Port, that might be the reason, that would fit in your issue description. No hurry, keep my fingers crossed.

I’m getting the same error, no proxy settings. We have the same AV at other sites which don’t get this error. Where is the log file location referenced in the error – “Internal error: java.lang.NullPointException See log files for details” ?

Any news or solution for this problem? I’m having the same issue on version 6.0.4

Hi Guys, could you please open a ticket since it needs to get sorted out? Please keep us in the loop, if you get a specific feedback from our support?

Logged a ticket last week, referenced this slack thread. Awaiting update on ticket.

Seems like a few other users have this issue, like @member

I just double check this behavior in my lab, and it works there. @all: are you using a Proxy?

@member yes – there is a proxy but it is a transparent one in my case… so we receive an “ok” message inside the catalina.log file => iles/IGEL_UNIVERSAL_MANAGEMENT_SUITE/.properties/listfiles.php HTTP/1.1 = HTTP/1.1 200 OK

Hello, we have the same problem. (Internal

We have make a new Installation from last Version UMS6 with a new Server 2016 Enterprise but than we have import the Backup from 5.09.

No proxy, no Antivirus, no firewall. The connection test is green.

Have checked a few of our clients, we have two UMS working, two broken. All upgraded to various UMS version 6’s. Image attached. 6.03’s working. Same AV across sites, no Proxys.

Upgrade the non working, 6.02.110 to 6.03.110. Issue persists (not version related?)

I‘m still a bit convinced that it has a relation to this change:

Broken UMS can reach the xml page from browser, additionally the catalina log – response status of GET HTTP/1.1 = HTTP/1.1 200 OK

Comparing Catalina logs on a working and broken ums, both finish on – download of finished

Working UMS will show the ‘Universal Firmware Updates’ page, the other ‘Internal erro:java…’

I think the issue may be with the Target directory the UMS then uses for storing the firmware. @member do you know where this is set? Doing a manual upload of a Firmware, then sending to an IGEL fails. I can see the UMS is presenting it on the private IP ( from the firmware error on the IGEL.

Sure, Assuming you are on Windows:

C:Program DataIgelRemotemanagerRmguiserverwebappsums_filetransfer

Cheers, i can see my certs and firmwares in that location. The UMS then presents that via IIS (i think?) as servername/ums_filetransfer but checking from an igel its using the wrong IP ( instead of servername how do i define that part?

Via Tomcat, I would replace the 169 IP by the UMS IP in your URL pointing to ums_filetransfer don‘t forget servername:8443 the Port is defintely needed.

what file do i edit?

Usually just go to the firmware in UMS under Universal Firmware and there you can edit it!

I have tried this but the host value is not changed when looking at the error presented by the Igel.

next customer – same issue… after updating igel ums to 6.04.100 – looks like a feature 😉

Does anyone can provide an update a bout this?

Same here, going to open a ticket

Guess I will open a ticket also.

There is a fair bit of radio silence on this issue, not heard back on the ticket. Would be ideal if we got an update via the thread.

@member @member @member @member A new version of UMS – 6.04.110 is available with the following fix,


Resolved issues:


[Universal Firmware Update]

Fixed: The check for available firmware updates failed with a null pointer message if one of the downloaded firmware properties was invalid.“`

Please ensure to backup the UMS DB before upgrading.

UMS download link:

Thanks I will do so.

Continue reading and comment on the thread ‘Aftrer updating IGEL UMS the “Check for new firmware updates” fails with error “Internal error: java.lang.NullPointException”‘.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base

Ask a question or comment on the above message thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!

Popular Message Threads

Categories & Tags: