Anyone experienced the double hop mouse cursor issue on IGEL OS?

Good afternoon, has anyone experienced the double hop mouse cursor issue? We upgraded our Citrix VDA and we are getting reports of the cursor disappearing within Citrix applications. I was researching the slack channel about this and found a prior post in a similar situation but it seems there wasn’t a clear cut solution mention.

Learn more, read the entire thread inside the IGEL Community o Slack

Try this registry key on your first hop:

Path: HKLMSOFTWARE{WOW6432Node]CitrixICA clientEngineConfigurationAdvancedModulesThinwire3.0


Type: REG_SZ

Data: 0

And restart the computer after applying.

This was the workaround provided to us by Citrix and seems to fix it every time

We had a similar issue and fixed it by setting ica.wfclient.cursorstipple to Solid Black in the Igel registry. Going to have to Test Josh’s answer though since If I remember correctly the Igel setting worked but wasn’t perfect.

I have that cursorstipple setting applied via IGEL, as well, in combination with that VDA registry value.

I have the regkey in place atm. I will try that registry entry on the IGEL side as well. Thanks everyone!

It looks like the cursorstipple was the missing piece

Continue reading and comment on the thread ‘Anyone experienced the double hop mouse cursor issue on IGEL OS?’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base

Ask a question or comment on the above message thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!

Popular Message Threads

Categories & Tags: