Budddy Update clients take the update pack instead of the Buddy settings?

Hi Guys,

I want to use Buddy Updates for our Branch Offices. So I did create a Profile for Thinclients to automatically detect a Buddy in the Network. This is assigned on the Branches folder.

Learn more, read the entire thread inside the IGEL Community o Slack

On the Root Directory I have assigned a Update package.

Usually profiles that are closer to the Thinclient should override settings that are further away from it. But the clients take the Update pack instead of the Buddy settings.

Hi Till, usually, yes, you are right. Could you please Right click on on device that should get the Buddy Update Profile => Other Thinclient Commands => Settings UMS > Device, F5 Refresh and retry?

Just tried it on my Lab, with 6.01.130 / OS10 10.05.800 and 10.01.110, and it worked like expected.

i did this allready. I also have tried to reset it to factory default.

Is Cache in use (UMS Administration=> Global Configuration=>Cache)?

I thought maybe because one is a update pack and the other one is a profile or something like that

yes it is

That might be the issue… I’m trying to get rid of it, made more problems than helped me… Ok, please disable it, save, restart the UMS Service (or Server), Re-push the settings and you should be good.

One last thing: Profile for Buddy Update is more or less on the same firmware version like on the endpoint, right?

buddy has 10.5.800 and the endpoints I want to update are on 10.4.100

I will try it.

Well, try also to set the profile on a “firmware based on” on 10.04 also, shouldn’tbe the root cause (I’m still on the cache topic) but it would be better

It did not help. I checked the Profile Version as well.

It is funny because if I open the settings in UMS it shows what i would expect but on the thinclient there are other settings

Reset to factory now, doesn‘t help?

sadly no

@member could you show us the screenshot of this device configuration from inside the UMS?

Dis is the UMS. When I double click the Thinclient.

And this is the Setup if I shadow the Client and open the settings

after you disabled the cashing in the ums, did you also restart the IGEL RMGUIServer Service? If not could you do this and check if you can push the settings again?

i did restart the whole windows server

hmmm – strange – and you also reset the device to factory defaults?


what version has your UMS?

6.01.100 (Build 40023)

i tried it here with UMS 6.01.100 and a device and get the same results – also with disabled cache

update section of the /wfs/group.ini:
















if i remove the firmwareupdate from the root, i get:








so it looks like a bug for me, where the firmwareupdate part is not replaced by the ftp-update-profile, but the ftp-part is “only” appanded – which should not be the case, i think

Will look on my OS11, UMS 6.02.100 in a few minutes and let you know!

Same here on UMS 6.02.100 and 11.01.110. UMS devices config is saying FTP Buddy, Device locally: HTTPS, Universal Firmware

I also tried to override it by using Master profiles, but no change…

I agree with @member it should be reported as bug IMHO. Could you please open a ticket at our support?

A small Update: The Developent Department means this is a wanted Feature and works as it should. But that it is displayed different in the UMS as on the Thinclient will be fixed in the future.

Continue reading and comment on the thread ‘Budddy Update clients take the update pack instead of the Buddy settings?’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base

Ask a question or comment on the above message thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!

Popular Message Threads

Categories & Tags: