Can’t login to UGEL UMS Web app, receive spinning wheel


Just installed UMS 6.05.110 on Ubuntu 20.04. Can log in with admin user to the UMS.

I now to try and login to the Webapp, but when i enter username and password (using credentials from above and also invalid creds) i only get the rotating circle at the login mask.

the stderr.log states:

ERROR HostConfig Error deploying web application archive [/opt/IGEL/RemoteManager/rmguiserver/webapps/wums-app.war]

java.lang.IllegalStateException: ContainerBase.addChild: start: org.apache.catalina.LifecycleException: Failed to start component [StandardEngine[Catalina].StandardHost[loca

lhost].StandardContext[/wums-app]]

at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:747)

at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:719)

at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:705)

at org.apache.catalina.startup.HostConfig.deployWAR(HostConfig.java:970)

at org.apache.catalina.startup.HostConfig$DeployWar.run(HostConfig.java:1840)

at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)

at java.util.concurrent.FutureTask.run(FutureTask.java:266)

at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)

at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)

at java.lang.Thread.run(Thread.java:748)

Any ideas on how to fix that?


Did you tried different browser also outside of the VM itself?


Only tried on browser outside of that vm (FF and Chrome).

wums-app.eer|log exist, but are empty


Did you tried to restart the UMS Service?

Different users?

Is there a SELinux enabled?


I ran into something very similar when I upgraded, and it was due to me being very stingy with the RAM, and the web server would not fully initialize. Can you confirm the resources you have added to the UMS box? I had to go with 2vCPU and 8GB.


> Did you tried to restart the UMS Service?

yes

> Different users?

no – but it does not seem to even check a user, as i also tried completely non-sense users – and had the same outcome

Edit: created extra user – same

> Is there a SELinux enabled?

no

Running on 2 cpus with 2 cores each and 8 GB RAM

but will give 16 GB for a test

no change


Could you uninstall, delete the /opt/igel folders and reinstall? Just in case…?


Is there an “official” uninstall command?

nvm – reverted to a snapshot

no change after reverting and new install.


Yes: /opt/IGEL/RemoteManager/_uninst/uninstall.sh

Will check on mine 20.04 in a few moments.

Same here on 5.4.0-48. (20.04)

Trying now 18.04

Works on 4.15.0-122 (Ubuntu 18.04).


Ok. good to know.

Continue reading and comment on the thread ‘Can’t login to UGEL UMS Web app, receive spinning wheel’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base



Ask a question or comment on the above messasge thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!


Popular Message Threads


Categories & Tags: