Chrome or chromium OS and Endpoint Verification is not picking up serial numbers on IGEL OS devices


Anyone used Chrome or chromium OS and Endpoint Verification on the IGELs? I’ve noticed the Endpoint Verification isn’t picking up the serial number on my device so its not working for the gsuite admin policies


As I understand it, you will need to install Chrome browser and then stick in the extension.

Here is link to build CP for Chrome:

github.com/IGEL-Community/IGEL-Custom-Partitions/tree/master/CP_Source/Browsers/Google_Chrome

Here are details:

support.google.com/a/users/answer/9018161?hl=en

The build script, see below, will need to be updated to include the native helper app (as noted in the link above).

github.com/IGEL-Community/IGEL-Custom-Partitions/blob/master/CP_Source/Browsers/Google_Chrome/build-chrome-cp.sh


Yea I have endpoint verification installed, it just doesn’t pickup the serial number for some reason

I was able to add the helper to the original script I think and build to get it working

It all seems to work like our windows computers, just not grabbing the serial number. Could it be the IGEL installed somehow changes how that is read on the computer?


So, I think, the endpoint-verification application is looking up this data? Maybe it is missing a library …?

Did you notice anything in the “endpoint verification logs”?

To help them diagnose your issue, download the endpoint verification logs and share them with your administrator:

1. On your device, open Chrome Browser.

2. In the Chrome browser toolbar, right-click Endpoint Verification and then click OptionsDownload Log.


ah good idea. I don’t think I looked there

So there are 3 lines that show how its getting the information.

Its using NativeMessagingRPCChannel to Invoke “Device/Info”, then

NativeDeviceInfoProvider to request device info with [osversion,diskecnrypted…etc}

CanonicalDeviceInfoProvider then to request the same as above

Working on getting the actual log though

[210211 14:01:29.37] [CanonicalDeviceInfoProvider] [FINE] Requesting Device Info with [osVersion,diskEncrypted,screenLockSecured,deviceSerialNumber,deviceModel,deviceHostName,deviceMacAddresses,deviceId,mtlsCertificateFingerprints].

[210211 14:01:29.37] [NativeDeviceInfoProvider] [FINE] Requesting Device Info with [osVersion,diskEncrypted,screenLockSecured,deviceSerialNumber,deviceModel,deviceHostName,deviceMacAddresses,deviceId,mtlsCertificateFingerprints].

[210211 14:01:29.37] [NativeMessagingRpcChannel] [FINE] #2: invoking ‘device/info’…


Okay… looking at the package for endpoint-verification…

has install script that does the following:

/usr/sbin/update-rc.d endpoint-verification defaults

/bin/systemctl start endpoint-verification.service

Can you open a terminal window as root and run those two commands

Here is CP build script that adds in endpoint verification package.

The following commands will go into your profile (System > Firmware Customization > Custom Commands > Desktop > Final desktop command)

/usr/sbin/update-rc.d endpoint-verification defaults

/bin/systemctl start endpoint-verification.service

and need to install the extension into Chrome:

chrome.google.com/webstore/detail/endpoint-verification/callobklhcbilhphinckomhgkigmfocg

To debug … turn on debug level

Updated the CP for Chrome — github.com/IGEL-Community/IGEL-Custom-Partitions/tree/master/CP_Source/Browsers/Google_Chrome


Thank you! I’ll give it a shot this morning

@member Thanks again for doing this. It seemed to work flawlessly. Its still not picking up the serial number. I’m going to open a ticket w/ Google and see if they have some suggestions

I’ll update here what they say


After you deployed, open a terminal window as root and run the following commands:

/usr/sbin/update-rc.d endpoint-verification defaults

/bin/systemctl start endpoint-verification.service

Then, per the picture above, turn logging to DEBUG and look at the log file …

and … maybe look at 18.04 Ubuntu system setup the same way, turn logging to debug and checkout the log file / compare logs between IGEL OS and Ubuntu 18.04.


Will do! I’ll do that after my chat w/ google support

So i’m not sure if it was a timing thing or your new package finally worked. The Serial Number is there, but still getting denied, but could also be a timing thing from Google’s end. So i’ll send out any updates on tuesday when we are back in office


Thanks for the update. Would like to get this item solved so we don’t have to re-do for someone else. Take care


Yup completly understand!

Continue reading and comment on the thread ‘Chrome or chromium OS and Endpoint Verification is not picking up serial numbers on IGEL OS devices’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base



Ask a question or comment on the above messasge thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!


Popular Message Threads


Categories & Tags: