Citrix Receiver keeps running on IGEL OS until the connection times out after a few minutes and the Receiver tries to reconnect


Might anyone have any ideas on how to fix this problem? When people log out of a Windows 7 XenDesktop virtual machine, the Citrix Receiver keeps running on the thin client (showing the virtual machine’s desktop background), until the connection times out after a few minutes and the Receiver tries to reconnect (it should just stop the Receiver process when the logout happens). However, logging out of Windows 10 works fine.


It might have a relation with the logoff process, just as workaround: can you try the profile linked in this thread and test it (maybe with some adaptions)?

igelcommunity.slack.com/archives/C8FC01UNM/p1557344823219500?thread_ts=1557156393.152500&channel=C8FC01UNM&message_ts=1557344823.219500


Fairly certain its this kb.igel.com/igelos-10.05.800/en/citrix-freeze-at-logout-14686550.html

I had the issue and can confirm disabling udp fixed it

Seems like the receiver client is waiting for some kinda close or fin but in my experience UDP would rather leave the conversation hanging


Thanks to both of you for your suggestions! Unfortunately, they didn’t fix the problem; neither disabling U.D.P. nor using Receiver 13.5 worked.


And importing the profile from the other thread neither?


Sorry, no, it didn’t… the keyboard shortcut naturally closes the Receiver window, but it didn’t help with making sure that he window closes when I log out (using the V.M. menu or the Igel menu).

It works with a virtual machine on a different vCenter — but that is also on a different virtual network and built from a different template.

I didn’t see anything blocked by the firewall.


I have a similar issue, when users log out of their XenDesktop or XenApp session (using Self Service Appliance Mode) they are returned to the Citrix Storefront instead of logging out of the session completely – so they have to log out twice. I have imported your profile, Sebastian but then I am unable to even login using it. When using the same storefront with a browser session, it logs out completely as expected


I’m so sorry… I should have reported earlier that we found the fix, at least for us: support.citrix.com/article/CTX232875

(even though the article says ‘cannot connect’, in our case, it was causing problems with logging out)

Continue reading and comment on the thread ‘Citrix Receiver keeps running on IGEL OS until the connection times out after a few minutes and the Receiver tries to reconnect’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base



Ask a question or comment on the above messasge thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!


Popular Message Threads


Categories & Tags: