Citrix sessions (XenApp and XenDesktop) showing very bad performance with IGEL OS 11.03.587 with CWA 20.06.0


Hi, i’ve updated some of our ThinClients to 11.03.587 with CWA 20.06.0. Same problem as with CWA 20.04.0. Our Citrix sessions (XenApp and XenDesktop) showing very bad performance. Every klick takes some seconds to be recognized and the screen refresh is very slow. Changed the receiver version back to 19.12 again… Do you have any ideas or maybe a solution? Thanks in advance!


Hi Kotzur, could you try to remove all Citrix Profiles and just keep a standard connection (no Multimedia, no h264 optimizations, etc…)? Which OS Version is in use on Worker side?


We have a similar problem. IGEL UD3-LX 50 with firmware version 11.03.580.01. Citrix VDA Version 1912. Everything is slow with the IGEL Workspace App Version 1912, with the Workspace App Version 1912 from OS10 10.06.179.01 everything runs smoothly. If we switch to the Workspace app version 1910 at OS11, everything will run quickly again.


Same here, with CWA 2004 and CWA 2006 ICA RTT and ICA Latency rise to the hundreds of ms and UX is pretty unusable.


Did someone of you tried my suggestion above? Is a Netscaler in place?


@member no Netscaler, Citrix VDA 2006, OS Windows 10 2004 – didn’t test with a new empty default profile yet


We have just updated to 1912 LTSR with UD3-LX 51 OS 11.03.580.01 and we have the same problem on our UAT system. The responce rate is in its thousands of ms ……


Can you try to disable in Registry:

ica.module.virtualdriver.nsap.enable

@all on 11.03.587?


Hi Seb, sorry this is all a bit new. is this the reg in the igel ? how do I get 11.03.587? cheers


Hi David, it is a Private build, not an official release (just to clarify😄):

igelcommunity.slack.com/archives/C8GP9JHQE/p1593698426471100 igelcommunity.slack.com/archives/C8GP9JHQE/p1593698426471100


Is this Doug Brown ? do I need this build for the reg key change to work ?


Yes, and yes😁


Cheers, downloading the update now. I have always used the UMS console for updates. Do I just import this one?


Will give it a try later tonight and report back if the reg key helps @member


@member download the zip and then this article should help:

kb.igel.com/endpointmgmt-6.04/en/firmware-archive-zip-file-universal-firmware-update-26035709.html kb.igel.com/endpointmgmt-6.04/en/firmware-archive-zip-file-universal-firmware-update-26035709.html


Thanks @member I managed to work it out and have upgraded one of my igels … it not good news. The experience is still very poor.

@member Just a update, changed the Citrix Client version to 19.10.0 and still the same. Tried 18.10.0 and the desktop is back working at the correct speed and reponce.


I know we have 18 in place in our production environment. I don’t remember why we reverted to that, but I know there was something.

I haven’t been able to do testing myself. Just got back from vacation, so playing catch up today


Ok, now that’s strange – no issues with my test device connecting from home through Netscaler. So it has to be related to the profile, I will test again with a pristine profile, created from scratch. @member


I tested the same and expirienced the same poor performance. Also Camera quality is very bad. I have tested with Citrix Apps and desktops 2003 and 2006 And CWA 2006. Performance is fine with 19.12 but camera is also bad and teams is then not optimized


@member Sorry for late response. On Client side i’ve tested with XenDesktop W10 1909 and XenApp SRV2012R2. No Netscaler (only for external connections). Tomorrow i can test the clean profile with only Storefront configured.


same problem here, after upgrade to 11.03.580 the performance in citrix session is really bad. Server 2012R2 VDA Citrix 7.15 LTRS


Could you all please open a ticket and keep us in the loop?


@member After some tests on weekend ive found no solution. Even with clean profile same problem. Any further ideas?


Not for the moment unfortunately, would you mind to open a ticket please?

We are investigating that topic with a colleague of mine, just a short question to all of you guys: which kind of devices are affected beside the UD3 already mentioned?

Is someone of you guys testing with Windows 2019 Build 2004?


In our case we have tested it with HP Probooks 650 G5 Notebooks


And which Windows Server build nr?


UD2 / Windows 10


@member Which UD2 (model number) and Windows 10 Build Nr.?


I am using a LG 24″ AIO running 11.03.587. Using the 20.06 Receiver adds 30-45 seconds to the login time vs using Receiver 18.10. I haven’t done much beyond testing login times.


Hi, were using Server 2019 (Version 10.0.17763 Build 17763), Citrix VDA 1912 and UD3 new generation (UD3-LX 60). Experiencing the same issue with CWA 2004. Reverting to 1910 brings performance back.


@member We use UD2-LX50. windows clients (Laptops, PCs) no problems with 20.06 workspace app. Only with our igel thinclients.


discussions.citrix.com/topic/409292-extreme-latency-with-workspace-app-2004-for-linux/ Same issue persists with CWA 2006. From what I see it only happens for direct communications to the VDA, as soon as there is a Netscaler proxying the traffic no issues @member


Thanks for pointing that out @member


Same here with the old UD3 LX modell Clients and Server 2016 with CVAD 1912 LTSR CU1 installed. Back to CWA 1910 and everything’s fine.


Citrix engineers are investigating – will report back as soon as I hear from them


We’re using UD3-LX 60’s and on 20.06.5 citrix client and am experiencing the same issues. problem disappears over Netscaler


Have you guys tried disabling UDP? In my case the high latency is gone.


Are you disabling UDP in IGEL even if you’re not using Adaptive Transport or UDP Audio in Citrix, anyway?


Sorry – just talking about Adaptive Transport / EDT. Disabled it in ICA Global an latency looks fine.


Yeah, I get where you’re setting it, but do you have EDT disabled in your Citrix environment? I’m just curious to know if this setting needs to be changed in IGEL even if you’re strictly TCP in Citrix (which we are).


We ́re using the defualt value in 1912, so if EDT is available it would be used.

Maybe this is also the cause that @member s setup is working through a Citrix Gateway because no EDT is configured on it?


We have Adaptive Transport disabled via policy in our environment. I didn’t touch the EDT setting in IGEL, but on 11.04.100, I see different issues. I can launch our Citrix Desktop just fine, and latency seems totally fine (all internal, nothing going through NetScaler). If I logoff the desktop and then launch a published app, it fails to launch. Rolled back to 11.03.580 and everything works as expected. Gonna upgrade back to 11.04.100 and test the other CWA clients.


EDT over Netscaler had no issue. Didn’t try to disable it for internal connections yet


@member did you get any feedback from the ctx engineers yet? It should be a big point at their todo list… :face_with_rolling_eyes:


@member Last update from August, 12: We are working on it

FYI: the issue seems to be EDT related. TCP has no issues, however when going through Netscaler EDT works too. So zhe latrncy only happens with EDT going directly to the VDAs.


Are you temporarily resolving it by disabling EDT in the IGEL profile?


correct, that’s what I did – hope there will be a fix soon


I may go ahead and disable it in my profiles just to be safe, even though we have EDT disabled in Citrix.


I disabled on both ends


In CWA 1912 it works without issues – somehow Citrix has messed it up with 2004/2006


Why so many of you have EDT disabled? Is the performance profit so weak?


in our testing, performance was worse with EDT enabled.

In theory, it sounds great. Just haven’t seen it turn out that way.


There’s a note in the 11.04 release notes confirming possible performance degradation when using EDT.


we experienced issues with 11.03 also

not the same issues, but issues with document scanning


EDT worked great for us up to CWA 1912. In the CWA 20XX releases there’s a bug Citrix engineers have identified the root cause and are working on a fix


FYI, the latest private build appears to address the slowness issue: igelcommunity.slack.com/archives/C8GP9JHQE/p1600356566411500


Yes it does – I had the chance to test a beta release of CWA 2009 from Citrix last week. It seems they fixed the root case and everything is back to normal with EDT.

Continue reading and comment on the thread ‘Citrix sessions (XenApp and XenDesktop) showing very bad performance with IGEL OS 11.03.587 with CWA 20.06.0’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base



Ask a question or comment on the above messasge thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!


Popular Message Threads


Categories & Tags: