Connecting local Dymo LabelWriter 450 Turbo printers to a Citrix session on IGEL OS?


Has anyone had any issues connecting local Dymo LabelWriter 450 Turbo printers to a Citrix session? Tried setting up as an Igel Printer, but it never maps to the citrix session unless another networked Dymo is setup for some reason. Also tried as a Citrix Direct USB device but then the default printer setting gets screwed up and always sets the Microsoft PDF Writer as the default until you delete all networked printers. Only way it seems to work is to wait a minute after citrix login and then plug the printer in, and make sure you don’t leave it plugged in when you reconnect or your default printer is forever messed up.


Hey @member can you send screenshots of the printer configuration settings you are using?


This is the setting I’m using for Native USB redirection.


Sorry, I meant the local printer configuration, not USB Redirection


These are the settings I had tried when setting up the printer locally using Igel. This printer would only appear if I had a different dymo shared from a windwos 10 machine installed on the VDI Session.


Just to add a few ideas to @member great thoughts, you added the Printer class to the USB Redirection class.

That might help, but if you are using local Cups printers in addition, I would disable the class on Redirection side; both set, isn‘t a good idea…


Locally to the VDI, the printers are sent to users using group policy.

@member I either tried the Cups Printers or Citrix USB Redirection. not both at the same time.


Thanks for that info. @member can you send a screenshot of the DYMO label printer driver as it appears in Windows?

SHould look something like the screenshot below.

Sorry, ignore the red circles, I had to find an image online from a Windows box 🙂


Here it is.

i was thinking if there was a setting in Igel to delay USB redirection at citrix desktop login for 60 seconds I could workaround this issue…


I don’t think that is an option. It’s all controlled by the Citrix receiver/workspace app


Yeah. thats what I figured. we already looked for a setting for that in citrix workspace and couldn’t find one. Not eaen sure if we could use the Cups method either since the software will not work unless it sees a Dymo printer and it might not like it being on a network or VDI share.


If CUPS redirection is working, it should show up as a local printer in the VDI session. Usually that just works.

Have you verified that the endpoint device see’s the printer?

You can see this by running the command below

lpstat -p -d

Wait, have I been reading this wrong? Is the printer showing up in the session, but it’s just not getting set as default?


Yes. I’ve even printed to it from the local Igel’s firefox, and it will map if the VDI session has another Dymo mapped from another win10 machine.


It could be an issue with the driver. You may want to open your image up, get the device to show up and install the driver. Then capture that image and push it to a test pool.

Then connect to that new pool from an IGEL configured to pass the device through and see if it shows up properly


I can give that a shot tomorrow to see if I can get it working through Cups. Pretty sure Dymo is doing something wierd with their drivers.


That wouldn’t surprise me either.


Any idea why the default printer configuration screws up when I don’t use cups and go direct USB?


Not sure, that’s something that is handled by Windows.

What exactly gets messed up?


if I gpupdate /force the session it will set the mapped printer as the default but it wipes out after a logout/login


Windows 10?


This is what sets up at every login. (using USB Redirection)

win 10 1903


Try this option

www.printandshare.info/kb/articles/00003/how-to-set-the-default-printer-in-windows-10-back


yeah that was one of the first settings we killed.


It’s something in Windows t hat is setting it, so I am not sure where to go from there.

Only other thing I can think of

support.citrix.com/article/CTX232031

Set it to Client Printer


We tried that too. Same issue.


Only other thing I can think of is checking event viewer in Windows to see if it tells you what is changing the default printer and why.


well thanks anyway. I’ll try taking a crack at it tomorrow any hopefully figure something out.


Good luck, if I think of anything else, I’ll drop a note here. I would be curious if you find a solution


Just to add to this if anyone runs into this in the future. We figured out why the Dymo’s were not adding through CUPS. Even though the Dymo software and driver was installed, it doesn’t add the driver to the print server until one printer is physically installed.

To fix this, You have to run printmanagement.msc, select drivers for the local machine, and verify that the driver is listed as a server driver. If it’s not you will need to install it manually. Once installed, it picks up the redirected printer with no issues.


Thanks @member that‘s great Feedback, thanks for sharing!

Continue reading and comment on the thread ‘Connecting local Dymo LabelWriter 450 Turbo printers to a Citrix session on IGEL OS?’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base



Ask a question or comment on the above messasge thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!


Popular Message Threads


Categories & Tags: