CUPS printeing in a RDP session on IGEL OS


Hi,

I have an issue with a cups printer in a RDP session.

I installed the Brother HL5450 Printer ppd at my Igel Thinclient, that works perfect (printing is possible).

I also installed the Printerdriver at the Terminalserver.

My main problem is that the RDP session doesn’t automount the printer. It adds an printer interface to the RDP (called 0001#: [ThinClientMac]) and If I install the printer manually printing is possible. If I use another thin-client the printer is there but it’s mounted on the interface of the other thin client.

If I unterstood the cups-rdp-sesstion correctly I have to ensure that my windows rdp an identify the driver that is identified by the drivername. That does work if I use a standard driver like the generi postscript driver. The my windows RDP is automounting the printer. But the quality is awful.

I think my cups config looks fine and the printerdriver is installed at the Terminalserver too. But It doesn’t work.

Maybe someone as a good hint for me?


Hi Helge, I would try to disable the USB Redirection, just in case. So, I would:

1) Disable the RDP Native USB Redirection first, on Igel OS

2) Follow this Citrix Tutorial (I know, you are using RDP) to have a PS Driver installed: support.citrix.com/article/CTX140208

3) Check the Eventviewer on Server side


Hi,

thanks for your answer. I already fount that answer here at slack and followed it’s instructions. It doesn’t change anything.


Then let me ask a fewthings:

which Windows Server version and which Igel OS Version are in use?


We use Windows Server 2012R2 and Igel OS 10.05.xx

The interesting thing is that when I use a windows default driver like the described postscript driver, then the automounting works perfectly.

I thinkit’s a problem with the driver name, that I haven’t specified it correctly in the cuos config (see the attached screenshots #1 Post)…+


Maybe a dumb question then: is there anything in Eventviewer on TS Side? Just in case, could you try to update one device to 10.06.190?


I checked all the Serverlogs. There was nothing special…

Actually I was wrong, we don’t have OS10.05.xxx OS10.05.xxx we have 10.06.190 in the room where I test that printer solution.


What happens if you try to use a Type 4 builtin Brother driver? Can you change the local printer setting to RAW / Generic instead of the custom ppd?


I would agree with @member about the local printer settings. One of my customers used the following settings with great results: kb.igel.com/igelos-11.03.500/en/mapping-local-printer-to-citrix-or-rdp-sessions-27246348.html


@member: I’ll try that tomorrow and give a feedback. tanks so far.

@member: I know that kb article. With this configuration I currently have I can install the printer at the terminal server but printing is only available If I’m logged in to this specific thin client. If I logon to another TC in that room (both have the same UMS profile) I can see the printer but the port is mapped to the other TC (it says that the port is inactive. it gets active if I log on to that TC).

Maybe some additional information: our purpose is a classroom. my students come in my room, login to the terminal server with their accounts and should be able to use the printer in my room. When they go to the room of my colleague I wanted them to use his printer.


@member sounds like you need a print server! 🙂


@member I don’t see the advantage of a print server. It’s easy and comfortable for me to add the printer to the room specific profile. The printers are all LAN attatched but I don’t want to install them all globally seeable at tge terminal server. The studens shall only See the printer at the room they’re in.

I changed the Printer-Settings in Cups to “RAW” and “Quere”. It doesn’t change my situation.

The printer is still not getting automatically mounted at the terminal server. If I install the printer manually and if I use the forwarded “printer port” it works perfectly but when I logon to another TC the port is different, that means I have to reconfigure the printer in the windows TS to get it working…..

So I’m still at the same point… mhm…

Is my driver name correct at the IGEL config? I just copied the driver name “Brother HL-5450DN series” and pasted it in the profile. Maybe there is the problem?


Did you tried another Type4 driver on server side like suggested above?


Sorry für my late answer, I needed some time to test.

My current Status: it’s Not working dependable. I tried other drivers, also the type4 printer driver. In general it seems like IT should work because sometimes (rarely!) The printer ist available after Login. But thats really rarely because if the printer is added correctly a simple logout an login ist enough to stop it working.

I also contacted the IGEL support, they nearly gave me the same ideas like we discused here.

I also updated to OS 11.03.580 and created new profiles for my testroom where I only added the RDP Connection and the printer. That also doesn’t help, the problem is still like I described.


Well, that‘s getting hard to debug tbh. but let me ask a few things:

• are they maybe more than one TS, and the printer works only on one (or some)?

• you could use the rdpdebugger to see if something is getting logged on the endpoint:


OK, I’ll try that on Monday. Yes we have a cluster of 4 TS and there’s also a loadbalance active. The driver is installed on all 4 of them (I checked that). The problem is on all of them.

But I’ll use RDPdebugger on monday and maybe that will give us some ideas…

Continue reading and comment on the thread ‘ CUPS printeing in a RDP session on IGEL OS’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base



Ask a question or comment on the above messasge thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!


Popular Message Threads


Categories & Tags: