“Error: Configuration forbids opening file dialogs” trying to establish a bomgar session from IGEL OS

Has anyone attempted to establish a bomgar session from the Native IGEL side? I attempted to hit our bomgar URL and open the download to start the session but I was met by this error. I was not sure if this was possible to even begin with but our ITSM team asked.

Learn more, read the entire thread inside the IGEL Community o Slack

“Error: Configuration forbids opening file dialogs”

Hi Alex, could you try to reset the device to factory reset, just assign one firefox Profile without any limitations and retry?

Which Firmware btw.?

Will do and its 11.05.120

I’m interested to hear if this works. We have Bomgar and would love to be able to use it on our Igels but haven’t tried it yet assuming it wouldn’t work.

Same pop up with a brand new browser profile with 0 privacy and security setup. I connected this profile to a device without any other profiles besides shadow and the same pop up occurs.

Enable file downloads in the browser settings. I had same issue downloading PDF files until I enabled that igelcommunity.slack.com/archives/C8GP9JHQE/p1619461340038200 File download link

Thank you Paul. This was successful on Chromium after doing this setting. We are still on 11.03.580 in our environment so for the time being I am gonna look for a Firefox solution but I will definitely keep this in mind when we make our standard firmware 11.05.120 (hopefully soon).

@member did you already tried this?

1. Changing the download path here (kb.igel.com/igelos-11.05/en/content-42011015.html kb.igel.com/igelos-11.05/en/content-42011015.html) to some of these paths:

kb.igel.com/igelos-11.05/en/browser-cannot-download-files-42009687.html kb.igel.com/igelos-11.05/en/browser-cannot-download-files-42009687.html

yes, I am just wanting to download to a temporary place for the .exe to launch. I tried userhome as shown below but the same error message for firefox occurs.

I did also try the default of userdefined and /tmp

Ok, just a canon shot for a little bird😉, you could try to disable Apparmor profiles, reboot and retry:

Registry, System, Security, Apparmor

I’m late to the party, but aren’t you’re missing this settings for your firefox?

That’s what I thought too, Jo, but it didn’t work either with a blank configuration without any setting made.

But with no settings made the file system is hidden (no file dialogs)/no downloads, or?

Time for more coffee… Right… Sorry!

I guess it’s the wording with “Hide…” I find this also counter intuitive in regard to checkbox and have to think twice.

I will enable “Hide local filesystem” but leave it unchecked to see if this stops the error from occurring

Awesome. As for firefox it looks like this did the trick. The only callout I noticed is that you gotta click on the folder and not the .exe as shown below. You then can follow the bomgar prompts as shown in the second pic

Any negatives to not hiding the local filesystem since its hidden by default?

You’re giving up a basic security aspect not to be able to download random executables from the internet and start them. This is why it’s disabled by default. Instead only file types which are known are started by an integrated application.

Understood, I figured that much. Definitely something to think about. Thank you for the help as well.

Continue reading and comment on the thread ‘”Error: Configuration forbids opening file dialogs” trying to establish a bomgar session from IGEL OS’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base

Ask a question or comment on the above message thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!

Popular Message Threads

Categories & Tags: