Error connecting Firefox Browser Session to Cítrix Storefront: Error “Cert Authority Invalid”


Hi, having trouble with OS 11.04.240 and Domain ROOT-CA Certs.

When i configure a Storefront Session via UMS the certs working well but if i configure a Firefox Browser Session to Cítrix Storefront i’ll get an Error “Cert Authority Invalid”. This happens on Chromium Browser Session as well.


Hi Christian, which certificate type did you choosed?

kb.igel.com/endpointmgmt-6.06/en/registering-a-file-on-the-ums-server-37282459.html kb.igel.com/endpointmgmt-6.06/en/registering-a-file-on-the-ums-server-37282459.html


I‘ve tried common and Webbrowser and also undefined


Could you check the presence of the certs in /wfs/ca-certs/ (when choosed common) and doing a more /wfs/ca-certs/yourCACert.crt ?

The file should start with Begin Certificate.

Did it worked before 11.04.240?


I‘ve checked this already. The certs are still there. The customer is on Upgrade process to OS 11. So it is the only Version i’ve tried yet.

On OS 10 same certs are working well

I‘ve restored to factoy defaults – same Problem.


please check the more command then please, keep my fingers crossed.


FYI: 11.04.240 still has the certificate deployment problem with Certificates given in DER format. Fixed in 11.04.245. But if your cert is already in PEM format, then this is not the reason.


Found out the issue. I’ve exported the wrong cert format. Always use Base64. Thanks

Continue reading and comment on the thread ‘ Error connecting Firefox Browser Session to Cítrix Storefront: Error “Cert Authority Invalid”‘.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base



Ask a question or comment on the above messasge thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!


Popular Message Threads


Categories & Tags: