Error connecting to Citrix StoreFront “Error adding store: Http error[302]”


We have a customer trying to connect to Citrix Storefront and shows this error.

“Warning” [StoreFront] Could not connect to the Citrix server.”

“Error adding store: Http error[302]”

Can anyone help us?

Thanks


Change the path to store to Citrix/Store -> StoreWeb is only used for browser based access. Of course use the appropriate storename


Thanks for the answer, but the problem persists. Any idea? Same connection, user and password from IGEL browser (Firefox) works fine.


I’m working on this exact same issue. ๐Ÿ™‚ Hopefully one of us finds a solution soon!

My Citrix admin is thinking that we’re running into an issue with the version of Netscaler that we’re on. If that’s the case, then I won’t be able to test again until hopefully Monday. I’ll update again once I can do some more testing! ๐Ÿ˜„


Hi All, I’ve worked on a few cases where changing the value under: Citrix > Citrix Global > Options > HDX Adaptive transport over EDT works when you get the ‘error adding store 302’ error.

Let me know if that doesn’t do the trick and you can always open a support ticket with myself or another member of the team ๐Ÿ™‚


Not worked for me, but thanks. Already open a support ticket to verify the cause.


Try to go directly to the Storfront. If this works you know the issue is related to the Netscaler implementation.


I too tried @memberโ€™s suggestion, none of the options changed, still getting the ol’ 302 error. My Citrix admin did mention that in some patch notes for our Storefront that a “workspace enabled storefront” setting is added, which we currently don’t have. So ultimately our Storefront might be the thing we need updated, not the Netscaler (I misspoke earlier). For reference, my coworker says it’s version 18.11 of Storefront that shows this new setting. ๐Ÿ™‚ Hopefully we’re able to get this update done this weekend!


I had the same Issue as we where using this on the local network we had to use the citrix store but on the end with .lan instead of .com and that solved my issue


Well, we’ve updated our Storefront and we’re still having the issue. So, as @member suggested, I attempted to connect directly to the Storefront instead of the Netscaler, and everything worked fine. So, at least now we know it’s to do with our Netscaler somewhere…somehow. Anyone else have any progress with this?


I ฬm waiting for customer answer to follow up with IGEL support ticket. I will inform you with any news, but it seems to be an issue with Citrix Gateway (aka Netscaler).

We can connect !!! Basically we let blank Path to Store and Store name from my first screenshot. Then, configure Sessions > Citrix > Storefront > Server > Session login > Authentication type > Citrix authentication (Smartcard disabled) instead default option, works fine, but you have to type 2 times user/password.

Jennifer, Could you test it?

If you use default option works, too, but you need to delete space in front of user.


Thank you @member that worked for us! Hmm although the double logon part is going to have to be fixed. At least we’re able to successfully connect though, so it’s a step in the right direction! ๐Ÿ˜„


Double logon seems to be an issue with Citrix configuration, basically Netscaler. You can contact with Citrix support or open an IGEL support ticket to ask for NetScaler_for_IGEL_Connections.pdf tech note.

Continue reading and comment on the thread ‘Error connecting to Citrix StoreFront “Error adding store: Http error[302]”‘.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base



Ask a question or comment on the above messasge thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!


Popular Message Threads


Categories & Tags: