Error: “Couldn’t Resolve host name” updating firmware over IGEL ICG

Hello, We are trying to update firmware over ICG. We follow the documentation OS Firmware updates step by step documentation and have created a ICG Firmware update profile and assigned it to a device. When we try and update the device we get the following errors: Error: Couldn’t Resolve host name. Error: Access to URL ‘’ failed. Error: Couldn’t resolve host name. Error: Access to URL ‘’ failed. Error: Cannon get info from the update location. Error: Firmware update failed. Error: Failed to resolve host.

Learn more, read the entire thread inside the IGEL Community o Slack

Hello Richard.

Is your Update Server a separate public server or the UMS itself?

Hello Sebastien, Its a public FTP server

Thank you! Can you screenshot your profile and share it without the hostname?

Btw.: can you access the update files by using Filezilla and same creds.?

I was able to access it using WinSCP

Could you try to rename the folder without special characters? Same on password (at least for testing)?

Same result. I did notice another error UMS Agent – Error: Failed to register the device at the UMS. Not sure if that’s at all related.

It might. Can you send other commands like reboot?

Yes i’m able to send a reboot command.

Is the device holding a valid EMP Subscription?

Yes and it does show licensed in UMS under License Information

Did you remove the server name from your profile before posting? Also, I need to verify, but I’m thinking you need to remove the / at the front of the server path. Again I need to verify that last one, but I don’t recall mine having one there.

If you open a local Firefox Session, and you enter the ftp path, cam you access it from the endpoint side?

@member I think it is the missing server name, because the error message says that it tries to connect to but it should connect to you own server. You will have to put the FQDN or IP of your public FTP server there. The server path should be OK, if you put the IGEL_OS_11-11.04.240 folder in the ftp root on your server. If your ftp server is running on Linux or BSD be aware that filenames and folders are case sensitive.

I did remove the server name before posting the profile. I will verify the server name field is correct and also test opening firefox on the endpoint and seeing if I can get to the ftp site.

And I verified there are no slashes in mine (with either the server name or the server path)

In the server name there should be a FQDN or IP adresse, so slashes are not allowed. For the server path both could be OK – relative or absolute path. So there it should depend on the ftp server configuration.

I was able to open a local Firefox session from the endpoint and get to the ftp site. I changed the server name to the IP address but still no luck. I think going back to the Error: Failed to register the device at the UMS that it may not be fully getting profiles applied to it. I added a profile to the device to see if it would show on the desktop but it has not. If I right click on the device and edit configuration it shows as having the profile settings but the device its self seems to actually fail to receive them.

When I try to push settings to the device via Other commands – Settings UMS -> Device it fails with an error code 500.

Seems that the ICG assistent did not run correctly. It happend to a few devices for us, too. In all cases the device had been deleted in the UMS but was left in the recycle bin. I deleted the device from the recycle bin in the UMS console and ran the ICG setup on the device again after resetting it to factory defaults. After that it could be successfully registered. After that the profiles should get assigned correctly to the device and (if the update profiles settings are correct) the firmware update should work.

In our case the device is still showing in UMS it hasn’t been deleted.

Thank you all for your help. I ended up running the ICG agent again on the machine and the config took correctly the second time. I was then able to apply profiles correctly including the firmware upgrade and ran the firmware upgrade successfully. I am finding that it takes a little over a minute after boot up for the client to register with ICG is this normal?

The device I use takes about 10 seconds after my network is connected.

Our devices also take only a few seconds after the network connection is establisched to succesfully connect to the ICG. If you count the whole boot time from pressing the power button to successful connection to the ICG an minute can be normal – it depends one the devices hardware and configuration. What IGEL hardware do you use?

We have the IGEL OS running on old Lenovo 440 laptops currently for testing so it’s not the greatest hardware.

Thank you Richard for that feedback! Which part is the bottleneck and how did noticed that?

We have a few Lenovo T540 (with Core I5 Haswell cpu) installed and are at least as fast as our IGEL UD3-LX50. If you use WLAN the connection sometimes takes a bit longer but that is expected.

Continue reading and comment on the thread ‘Error: “Couldn’t Resolve host name” updating firmware over IGEL ICG’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base

Ask a question or comment on the above message thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!

Popular Message Threads

Categories & Tags: