Error “Fehler bei Firmwareupgrade, HTTP-Fehler” updating IGEL OS

I try to update my one and only virtual thin client in my lab from 11.01.100 to 110.01.120. So in UMS I drag and drop the firmware (Universal Firmware Upgrade-item) to the client and choose update on the client-item.

Learn more, read the entire thread inside the IGEL Community o Slack

Almost immediately the client shows “Fehler bei Firmwareupgrade, HTTP-Fehler”. In the details there is an HTTP 401 (authentication error) and other things showing up.

So to check for typos and stuff I copy and paste one of the file-URLs from the error message and open it directly in the clients browser. Firefox asks me for the credentials as it should. After successfull authentication I can download the file.

So I wonder, why the update mechanism is not authenticating. I’m pretty sure I got username and password right… Any ideas?

Is your user as “IGEL_INTERNAL_FIRMWAREUPDATE_USER”? I mean, did you you upload the firmware zip file manually to UMS and did you changed something on user / Pasword?

I used Universal Firmware Update. Uploaded the firmware to a local FTP server (vsftpd) and mirrored it to the webhosting.

Then I changed the Firmware Update Settings on that Universal Firmware Update-item (110.01120) to match the webhosting destination.

The username and password (and everything else) is what is necessary to access the webhosting.

Please do me a favor, can you create a new profile, enter your informations there, and retry?

I mean System,Update,Firmware Update

The manual way I try to avoid. Will do:-)

This one worked. I used the exact same settings. (Copy’n’pasted everything from a notepad as before. See comparison in screenshot.)

It should be possible to change values in a Universal Firmware Update-item, right? I mean the client gets the new server and path infos. It only fails to auth…

Iw ould assume, that the Universal Firmware Update is waiting for “something” beneatch ums_filetransfer. So, you could retry your behaviour by recopying the stuff under ums_filetransfer and see if that works. Well, I would say no; most of my customers are creating profiles instead of using universal firmware update.

Hm. After successfully updating the firmware to version with a profile as you suggested, I’m now able to use Universal Firmware Update.

That means: I’ve removed the profile and rebooted the thin client. According to UMS the client didn’t have any update settings anymore.

Then I applied firmware with Universal Firmware Update. And downgrading worked.

Now I’m currently updating again to with Universal Firmware Update and it works as well.

No idea, what I did to achieve that. I mean, Universal Firmware Update does the same thing to the client configuration as creating a profile.

Hmm… Anyway! Thanks for your help!😎

Continue reading and comment on the thread ‘Error “Fehler bei Firmwareupgrade, HTTP-Fehler” updating IGEL OS’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base

Ask a question or comment on the above message thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!

Popular Message Threads

Categories & Tags: