Error: “HTTP response code said error: response code: 404” updating firmware on IGEL OS

Hello, I am having issues updating firmware on IGEL from UMS. Recently I deleted all firmware, re-downloaded firmware, created new profiles, made sure paths to firmware matched up properly, rebooted IGEL UMS server, verified on UMS directory firmware files existed, still have issues, See screenshots.

Learn more, read the entire thread inside the IGEL Community o Slack

“Error: HTTP response code said error: response code: 404.”

Any ideas. I can’t upgrade my firmware to OS11. I have licenses available BTW.

Hello, to verify permissions you can use your favorite browser, connect to UMSSERVERIP:8443/ums_filetransfer, login as your admin account (specified during UMS install) if you can do that , 8443 is open, check. try to download a file, if you can do that, read permissions are OK, check. If you can put a file there, write permissions are ok, check.

One thing I have found is that creating a host entry for the UMS server in a separate profile and assigning that to your devices can resolve this issue.

@member Thanks for the reply and post. Yes I can access the UMS server and download a file. That tells me there is nothing wrong with the UMS server. I wonder if there is something I am missing on the IGEL device i.e. network setting, DNS issue, I will start testing now to take a look. Great feedback bud!

@member you could then try to open a browser session on the endpoint and retry that process. If that works, we could sort Network out!

@member 404 means that the target wasn’t found.

On a standard UMS Server the port for filetransfers are 8443., validate that you have the port in the address to the firmware (umsserverip:8443/ums_filetransfer…… )

Hi @member did you find a resolution to this problem? I’m facing the same issue with firmware download/upgrade to OS11.

@member did you tried the upgrade tool to see which step is missing?

Can you access the server path when using a Browser Session?

i can ping server the name form the UD3.

i have tried from a Windows machine. Yes i can but it prompted me for authentication first. Then i could access the path.

From what I‘m seeing: there is a (1) in the path with a blank at the beginning. Please try to delete the Firmware under Universal Firmware Update and redownload a newer one instead, like 11.03.100

Looks like that was the issue. Thank you so much for the fix and quick responce!

You are welcome! Happy to help!

Continue reading and comment on the thread ‘Error: “HTTP response code said error: response code: 404” updating firmware on IGEL OS’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base

Ask a question or comment on the above message thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!

Popular Message Threads

Categories & Tags: