Error: “License: A Workspace Edition license is required to start the upgrade process.” trying to upgrade IGEL OS

Hi, we try to upgrade one OS10 UD3-LX but as far as we know all the settings are ok but we still can’t get passed this screens because of the update source error. What are we doing wrong?

Learn more, read the entire thread inside the IGEL Community o Slack

“License: A Workspace Edition license is required to start the upgrade process.”

So you already have a license for that device on OS11 (ald or local one) and you assigned the firmware 11 to the tree where the device resides?

No, demo license does not work?

No, unfortunately not😌

Then I think we know the problem 😉

to test the upgrade we used eval OS11 licenses that i gave the mac addesses via de activation portal and loaded into UMS.

Ok, have to rewrite my post clearer: Upgrade from a OS10 Demo license to OS11 (incl. license migration) doesn’t work. Starting with a proper OS11 like on @member works of course.

@member Did you get pass this I was having the same issue and deployed a licence manually to it- as well my update source was being hamered by a profile i set

Good day. We too are getting this error, but only for the update source part, since the license is ok. If we try to set up the FTP Update source configuration through the setup or the profile, we are unable to let the upgrade work. The process gives back errors regarding some files (lxiv.ver/lxiv.inf) not found. We’ve checked but those files are present only in OS10 firmware package. Which files does the setup exactly need to find in the update source?

@member Good day, too! Can you send us a screenshot of the error and the profile you sed for the OS11 Firmware Update location?

Hello. Actually i’m not able to get another time the same error; now the process remains stucked on “Firmware Update”. The tools is still giving the error on “Update Source” regardless from which settings i use.

Thank you! Just for testing could you try to use a Universal Firmware Update element instead? Did you also activate the OS11 upgrade like described here:

Yes the settings for enabling the upgrade seems correct to me, considering my environment… Which package do you mean exactly with the Universal Firmware Update? The Should the package be extracted on the destination folder? I’ve already tried both methods…

Looks good, usually, I would the zip file, go to UMS,Universal Firmware Update,Right click,Firmware Archive -> Universal Firmware Update. Then it should look like this:

Yes i’ve shared this specific folder from Universal Firmware Update using ftp and the content seems to be correct, in fact if i use an external ftp client i’m able to read the content. However the Update Source it’s still in error

Got it but can you use the universal firmware update element (and letting it on https and 8443) and assign it instead of your FTP Profile to the endpoint and retry?

Ok, i’ve tried and the settings seems correct to me, but the error persist… I don’t know if in this config the user is required; the one that’s present in UMS is an user automatically generated (INTERNAL_FIRMWAREUPDATE_USER)

I might have be unclear, you can assign the Universal Firmware Update Element like a profile on the endpoint, like a profile via Drag & drop. Did you tried it this way?

Ah ok; yes it was the first thing that i’ve tried after enabling the upgrade to OS11 option, but even after several reboots it was keeping saying that was not compatible, so i’ve switched following the other steps of the guide regarding the update source. Now i’ve retryied and the upgrade package has been assigned without errors. I’ve launched the update from UMS and it seems to be ended successfully. That’s great 😄 Thanks

Awesome!!!! Yes, I know, when assigning it directly to the endpoint, it says: something like it isn‘t compatible but it is, of course. Assigning it to the folder where your endpoint is in, solves the issue.

Perfect; yes, actually, it worked even applyied directly to the device for me now. Probably a little more time or reboots are required after enabling the upgrade option in this case. Next time i will directly try to assign the profile to the folder. Thank You!

Continue reading and comment on the thread ‘Error: “License: A Workspace Edition license is required to start the upgrade process.” trying to upgrade IGEL OS’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base

Ask a question or comment on the above message thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!

Popular Message Threads

Categories & Tags: