Error: “settings don’t allow downloading files” logging in to Citrix Receiver on IGEL OS


Hey guys, I ́ve updated several (but not all clients in my environment) to 10.06.110.01. Using UMS 6.02.100.

So this one client (A) updated as expected, but trying to login via Receiver I get following error.

something like: “settings don’t allow downloading files”.

Clicking on cancel get’s me back to the CitrixReceiver login site.

Another client (B) in the same site works like expected.

Any ideas?


Hey, are you using a Browser Session for this kind of Citrix Session?


yep, through firefox


That‘s what I thought, I have to search a bit (already fixed it, but can‘t remember how…😬).

In the meantime:

can you check if the profiles firmware based on version is on the same version as the endpoint?

Can you check if Sessions,Browser,Browser Global,Content,Type of download directory points to userhome? If not, try to set it this way?


based on and endpoint version are the same.

the download directory is: /tmp (this is working on 40+ endpoints so far) 😕


But could you try to change it on that device? Just for testing?

And double check if the device belongs to that behavior even if you factory reset it?


will try and get back to you ^^

still: prior the update the connection worked fine.

cahnging the directory to userhome did not help 😕


Ok, then let‘s see if the reset to factory helps.


haven’t done this for a long time now.

this endpoint is not at my location. Will I be able to join the endpoint via UMS again? There is no one who could help me join the device manually at this location..


If network ports are all opened, and your device gets a DHCP Adress, yes, it should😄


factory reset has helped!

Unsure if this behaviour will repeat. There are still 100+ endpoints which have to be updated 😮 factory resetting them all is not a viable option xD


I don‘t think so, but it might be related to an old setting which wasn‘t set properly, hard to say tbh! But I will keep my fingers crossed, that it was a one time issue👍


Erik wich Backend Version you use in Microsoft/Citrix. I work many with Ctx and Igel and diesnt see this never…. :/

Continue reading and comment on the thread ‘Error: “settings don’t allow downloading files” logging in to Citrix Receiver on IGEL OS’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base



Ask a question or comment on the above messasge thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!


Popular Message Threads


Categories & Tags: