Error: “this function is currently not available” on IGEL UMS Web App

Hi, we’re having some issues with our IGEL UMS Web App. The device overview throws an Error: “this function is currently not available”. Also the novnc Viewer is not working.

Learn more, read the entire thread inside the IGEL Community o Slack

We are getting the same on the new UMS version


Hi! Would you mind sharing the UMS Version and how many RAM you assigned? Are you using embedded DB?

@member in every browser? locally on UMS or also from remote?

Remote on Google Chrome. We are using the embedded. However I only use the Main UMS console so not really a big deal for us, but thought my input could be helpful

I beleive the server has 8gb of ram but I can double check

We do use Version 6.07.100 and we are using the embedded DB. Our Server has 4GB of RAM. It ́s also not a big deal. We are currently using the Java-Client, but we want to switch 🙂

confirmed 8gb of ram

That might be the reason…

On UMS 6.07.100, with embedded DB and UMS Webapp, we expect at least 9GB Ram.

UMS with UMS Console, Embedded Database, and UMS Web App

When the UMS Console, the embedded database, and the UMS Web App are included, the RAM and disk space requirements are increased as follows:

At least 9 GB of RAM

Good to know!

I can see if that fixes it, but probably can’t do that until next week

I just bumped up the RAM of our VM to 16 GB. Sadly no difference.

Could you check @member on

UMS Server: IGELRemoteManagerrmguiserverlogs, Catalina and WebUMS Logs for something useful?

The wums.err.log shows, that there is an permissions issue. Because we are using LDAP Authentication i checked if the igelums user has the right to read the directories. It does ! Strangely enough the rights of our admin users should be able to read the directories as well. By the way. It did not solve the novnc problem.

So @member you say that using the main (local) UMS Admin doesn‘t show the error but Vnc doesn‘t work right?

Just in case, did you tried another browser type / OS?

The local UMS Admin is fully functional, including VNC. I tried Firefox, Chrome, Internet Explorer and the new Microsoft Edge ( Chromium ). noVNC is not working in each browser. Is there a log file for the VNC “webapp” ?

Dumb question, but could you create a new local user with full rights: on system, admin accounts and also on one folder with an endpoint in it. Does that work?

Continue reading and comment on the thread ‘Error: “this function is currently not available” on IGEL UMS Web App’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base

Ask a question or comment on the above message thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!

Popular Message Threads

Categories & Tags: