Error trying to upgrade IGEL OS 10 to OS 11 – “Error: Failed to downoad data”


I am trying to upgrade from os 10.06.130.01 to os 11. I am getting the following error.

“Error: Failed to downoad data”

The igel is looking for LXIV.ver and the os 11 that is downloadable from the igel site has LSOS.ver.


Check your update profile, it looks like you have an extra forward slash “/” in the path


no extra slashes in the path.


The path contains two slashes just before lxiv.ver. perhaps that’s something you have/can configure?


it is looking for lxiv.ver but the os11 downloads only have lxos.ver. Where is the os 11 download that has lxiv.ver


Did you extract the downloaded zip file to that location? It it has to be extracted


Ahhh typing too slow obviously… But obviously OCD is all over the place 😉


Yes it has been extracted.

I don’t have any issues with older v10 firmware. Only with os11.


What version of OS 11 are you going to?


11.02.150


Let me download that package and take a look, I have upgraded to OS 11 just fine, but not via a separate FTP server


here is a list of files from the os11 that i downloaded.

all the files start with lxos but the igel is looking for lxiv


Do you have the checkbox next to “Allow OS 11 upgrade” checked?


Yes


It’s odd, because that file naming convention doesn’t exist


here is my profile for upgrading to os11

Yup. not sure why my igel is behaving this way

I have a ticket open with iGEL but having gotten any call back yet


OK, copy the lxos.ver to a seperate lxiv.ver


it is a no go on that one


Hey @member, I see your case. IGEL support is a bit backed up right now due to an influx of incoming requests.

If you download the files using the UMS built-in update mechanism and use the firmware there to update does it work?

Hey @member, I just realized that there are two different error messages there. It looks like DNS resolution issue may be the root cause


@member The error window first has a message about not being able to resolve the hostname.

The update will try to do a normal update, if any of the pre-conditions in the tool aren’t met, so that’s why it searches for lxiv stuff.

This should be either a typo in your update settings, or some issue with DNS in your network. Once that’s fixed the upgrade tool should be all green as well.


@member It is a generic message. I have no issues with downgrading or upgrading version 10 from the same server. the problem is that the igel is looking for lxiv.ver and all the os 11 versions on the igel download page are lxos

here is a screenshot of the error and the iGEL resolving the host name


Hey @member, can you send upload the that configures the update settings to the IGEL case?


Downloading os 11.02.150 and deploying it to an igel via UMS works. However, that won’t work for us. We have distribution centers all over the US and need to utilize a local server (at the distribution center) to push the firmware. Seems to be an issue with using FTP or HTTP

@member I just responded to the tech support e-mail and included the igel profiles used for configuring the Firmware Server and Firmware Path


I would really like to hear how you resolve this issue, this is what I’m experiencing on our UD Pockets when I try to upgrade from OS10 to 11. I had no problems with my external converted laptops, nor my internal UD3 devices. Yet with the Pockets I’m beating my head on my desk because I keep getting the exact same error whenever I try to upgrade.


After troubleshooting with iGEL Tech Support. I had to setup a service account and apply it to the User Name and Password under Firmware Update. Never had to do that with any of the OS 10 upgrades. However, I am able to upgrade our iGEL’s to OS 11.


I’m having the exact same issue. what access rights did you have to give to service account and at what level? The service account is probably an Active Directory account? You are using a separate ftp server? Not the UMS itself?

Problem resolved. When supplying the hostname do not use the FQDN, just the name of the server.


Interesting, I wonder if you had done a hosts file entry on the IGEL devices with the FQDN if it would have worked


Hmm after installation it boots to grub> prompt?


Can you send a screenshot? Not sure what you are seeing


Interesting, what version were you on, and what did you upgrade to? I have never seen this, but will pass it over to see if anyone else has.


From version 10.05.830 to 11.01.130

Another update on the case: it was not the hostname that was the issue. It is the portnumber that isnt used when the profile is base on firmware 10.05.830

If I create the same profile base on firmware 10.06.100 the portnumber (8443) is used (HTTPS).

I did hower land on the same grub> terminal again after the update.


@member, are there any error’s shown before you are dropped to the grub command line?


No, all green checks during installation.


What about when it boots?


Nothing, straight to the command line

This seems to be hardware related. I’m having this issue on a Lenovo Thinkcentre M710q. On an LG 24CK55 the update works perfectly.

In a test environment this is fine but before rolling out to production I would like to resolve this issue. Any ideas?


The only other thing I can think of is something in the BIOS messing with the installation/boot


Did you only update one Thinkcentre? Or multiple of them, and all have the issue? Just a brainfart, what if you type “init 3” I had something like this years ago where my test device had a faulty keyboard that triggered to start in a safe mode (not quite sure how Igel calls it), Support then asked me to type init 3 and it continued, then later I figured out the faulty keyboard.


The stick installation works perfectly on the same hardware, with same bios settings or is this not a reference?

Continue reading and comment on the thread ‘Error trying to upgrade IGEL OS 10 to OS 11 – “Error: Failed to downoad data”‘.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base



Ask a question or comment on the above messasge thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!


Popular Message Threads


Categories & Tags: