Error: “Unable to load details for the tree nodes. Original error message: null.” after upgrading to UMS 6.04.100

Anyone get this error after upgrading to UMS 6.04.100? It doesn’t decrease any capabilities as far as I have seen but it’s weird and annoying.

Learn more, read the entire thread inside the IGEL Community o Slack

“Unable to load details for the tree nodes. Orignal error message: null.”

Hi Joshua. Basic question: did you restart the server or at least the igelrmserver-service?

Also open the UMS Administrator app, go to databases and check, of the DB is active. You can test it there as well.

Tested the database. That’s active. Can’t recall if I restarted the server. I’ll test that now.

Server reboot fixed it. Vielen Dank Udo!

Whoops, spoke to soon. It only occurs now when I click on the Jobs tab in the Server window. I can select through different jobs already created, but it does not give me any normal “Jobs” options.

Are you using the internal DB or an external one? If you use the internal, have you tried to run the DB optimization?

Internal. Tried the optimization, still getting the error.

We have the same problem and no fix. Support ticket opened.

I’m seeing the same thing. Also saw that the Server status is no longer green, nor is the Load Balancing status in this version of UMS.

Seeing the same as you Nick, although our environment only has one server.

Could both of you please PM me the ticket number so I can connect them in our system?

Sorry, I downgraded back to 6.03.130 and restored the DB since we didn’t have time to troubleshoot (trying to get Prod setup).

2020021910001725 is mine. Thanks!

Thanks Joshua, added a comment for my colleagues.

I just tried to update to 6.04.100 after installing and doing a reboot I was unable to login to the UMS with any account. I went in to the UMS Admin and made sure it was set to use my SQL DB not the internal DB. I took a snapshot prior to the update and reverted back. Going to wait a few days to see if anyone else had this issue.

Good evening everyone,

i haven’t yet given up the error and the new UMS version. Apparently, according to the support, our case is not as common and there is no solution. A downgrade was suggested to me, which I think is a shame for the new version that I would like to use. In addition, a downgrade to the previous version could have major consequences for us, since I would have to use a DB backup of this previous version there and eventually registered devices and changes will be lost since the last week, so this argument alone makes a downgrade not possible for us.

In the meantime, I am trying to deal with the error myself, since the support had no solution ready, at least with the active support for the latest function. What I have as an approach is the LDAP connection that we use for our UMS login. Because as a temporary solution: Logging in with the UMS internal admin account without LDAP allows you to work with the UMS without errors, even with the Jobs tab.

…and yes, I’ve already reset the LDAP-connection. This showed no improvement.

@member and @member is that an another solution? Or @member do you have any updates in your support ticket?

@member do you have the same error like we get? If yes, I mean you can click the error messages twice away and then you are logged in in the UMS.

Good morning everyone,

i got another answer to the support ticket.

I quote the answer below:

> I had a look in your logs. It looks like the objects in the UMS-tree have no value assigned “java.lang.NullPointerException”. Might be an issue in the updating process of the Database schema.

Can someone explain to me what exactly this is about and how I can fix it?

Morning @member I don’t have any update as of yet. They say they’re still researching the errors. We are not downgrading as of yet as it doesn’t really impact production, it’s just annoying.

Hello everyone,

@member, @member and @member.

good news for our issue with the jobs. My ticket was in the 3rd Level Support and I get the following message:

Thank you for your message.

In the meantime, I have learned from development that the cause of the error message that appears in “Jobs” could be found.

A fix will be created for this, which will be rolled out with the next release of UMS 6.04.110.

That’s good to hear. We also had issues with the server status and load balancing status both being “unknown” in 6.04.110, so we’re likely going to hold off on any update for a while.

You mean the version 6.04.100, that has this issues or? Maybe, a silly question, but that helps with our issue too, have you opened a ticket for your issue?

Yes, 6.04.100 had the server/LB status issue for us. I didn’t open a ticket because we’re finally getting ready for a Production roll out, and we really don’t have time to troubleshoot the issue.

we also have the same problem, do you know when the release is available?

I don’t know the next release date, maybe @member do you have more detailed information about it or can you ask internally?

@member I will ask and keep you posted.

Hello everyone, unfortunately I can confirm that I also get the error when trying to get updates at a customer with UMS 6.02.100 running, @member, is there any further information I can provide to help in this case?

Hello @member,

the 3rd level support has found the cause and will fix it in the next UMS version, version 6.04.110. So, I think, you don’t need to give any further information.

Thank you very much @member

Continue reading and comment on the thread ‘Error: “Unable to load details for the tree nodes. Original error message: null.” after upgrading to UMS 6.04.100’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base

Ask a question or comment on the above message thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!

Popular Message Threads

Categories & Tags: