Help redirect a USB device through an IGEL OS 11.03 client to a Citrix Virtual App server?

I’m trying to redirect a USB device through an IGEL 11.03 client to a Citrix Virtual App server. This has worked on a Windows client however I am having trouble with it on IGEL.

Learn more, read the entire thread inside the IGEL Community o Slack

Within Native USB Redirection the default rule is set to Allow (troubleshooting) and within USB Access Control it is also set to Allow by default.

I can confirm that the device is seen within System Information

Anyone able to give me a pointer?

Hello @member it would probably be better to set the default rule to Deny and use PID/VID to redirect the devices.

Setting the default rule to Allow can actually break USB redirection channels

Oh thats interesting. I’ll go ahead and make that change now πŸ‘:skin-tone-2:

Trying to redirect a device, and the USB hub that it is connected to usually causes problems πŸ™‚

I’m just confirming , the value is whatever comes after 0x right?

i.e. vendor in system information is 0xe53

I enter e53?

The Profile will not allow me to enter 0xe53

I’ve tried it in decimal as well. It hasn’t worked

Can you send a screenshot of your settings?

along with the device info from lsusb?

I’m reading the KB and it does state Hexadecimal needs to be supplied… but I can’t enter x 😭 I’ll try without 0x again

VID/PID should be

VID: 0E53

PID: 2516

But it may not be supported by Citrix

Not sure what a blynclight is

probably the capital letter let me down. I’ll edit again πŸ˜…

Its just a little light that lets people know the presence of a user. something my boss enjoys… but he managed to get it redirected from Windows -> Citrix. So we’ll get their eventually

Hmm… i’ll double check my Citrix Policies

@member thanks for your help today. I had to leave the office pretty sharpish so I was not able to complete my testing.

But I do appreciate your assistance, I will give it another go at some point over the weekend πŸ™‚

Sounds good

Combination of IGEL USB redirection and Citrix policies. Thank you v much @member πŸ‘:skin-tone-2:

See it’s the little things. If this didn’t work my boss would be upset πŸ˜‚

@member please can you share here both IGEL and Citrix policies? I am in a similar situation with a diferent device. Thank you very much!

Sure gimme 30m , I’ve got a P1 and I’ll post

Sorry for the delay. Mine started working without the Client USB Redirection rules being manually specified, but when enabled with the VID it still worked πŸ‘:skin-tone-2:

Glad you got it working

Continue reading and comment on the thread ‘Help redirect a USB device through an IGEL OS 11.03 client to a Citrix Virtual App server?’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base

Ask a question or comment on the above message thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!

Popular Message Threads

Categories & Tags: