Help setting up Fujitsu ScanSnap USB scanners with USB redirection?

Has anyone successfully setup any USB scanners with USB redirection? I am testing a Fujitsu ScanSnap S510 right now and can’t get our VDIs to see it. If I lsusb from the terminal, they see the scanner. My USB redirection settings are attached. My Horizon settings allow USB redirection and the View Agent also has the USB Redirection and Scanner Redirection settings enabled. FWIW I’m also using Imprivata Appliance mode. I have a ticket open with support but wanted to check with the community also.

Learn more, read the entire thread inside the IGEL Community o Slack

I know earlier versions of Imprivata Appliance mode caused issues with UBS redirection. What version of Firmware and the Imprivata PIE are you using @member?

@member I’m honestly not sure how to check. Whatever ships with IGEL OS 11

The Imprivata PIE is seperate. You can check the version by clicking the “Power button” on the appliance mode login screen, and clicking “About” (I think it’s about)

Oh right…we’re on

OK, that should be fine. Usually Fujitsu scanners work with USB redirection, but if not you can disable USB Redirection for the device, and try enabling SANE redirection to use the Scanner redirection built into Horizon, but the device has to have a locally supported driver in the OS

It looks like SANE does support this particular scanner. Does Igel OS ship with SANE drivers or would I need to download and install them directly to the terminal?

It has some, there is also an issue with Horizon Client and sane. I have a work-around, but I need to dig it up. Give me a few minutes here

So, try removing the USB redirection setting for it, and apply this profile. Reboot the device and see if it works @member

Great, I will give it a shot tomorrow. Thanks!

If that doesn’t work, it will most likely require a custom partition to load the drivers. IGEL’s Adavanced Services team may need to be engaged at that point to help build that out, test, and validate.

@member @member I’ve got 5 Fujitsu scanners up and running in Citrix non-persistent MCS machines. Since we have an explicit deny for most USB devices, we added the specific scanner PID/VID to allow those to pass through

yea, usually USB redirection works, but I have found with certain models that is not true

You’re definitely more knowledgeable than I. We really only had to add that specific allowance and everything passed through to our Win10 Citrix machines no problem. I’ll see if I can track down the specific model

okay, it is a FI-7160

Yep, the FI series scanners are the ones we have the most luck with

Turns out the ScanSnap S510 I was using is pretty old and I never could get it working, but I tested with another users S1500 and it worked perfectly. Thanks for the help guys.

absolutely. Sorry it was a hassle on your end

Well, false alarm I think. This works but is not reliable for us. The UMS policy is clearly set correctly because the scanner shows up in the VDI sometimes and I am able to scan, however if I log off the VDI and were to log back on, the scanner doesn’t show up and the View client shows ‘No Suitable USB Devices’. This happens every time. Through some combination of rebooting the VDI and the thin client, when I log on again it shows up properly…but then if I log off and back on it stops redirecting. Any ideas? I am leaning towards a View client/View Agent issue but I don’t know. Are there any logs on the Igel OS that I can look at to see if it’s passing the scanner through each time?

@member can you narrow it down a bit and find out if rebooting the IGEL fixes it, or if its’ by rebooting the VM that fixes it?

Also, are the VM’s persistent or non-persistent?

These are persistent VDIs. It seems like I need to reboot thin client for the scanner to show up again…

It may just be an issue with the virtual USB channel in Horizon getting hung up. Next time it happens can disconnect the VMWare session and then console into the device and run the following?

`killall vmware-usbarbitrator; /services/vvdm/bin/vmware-usbarbitrator`

Then relaunch and see if the scanner reconnects

@member this seems to work consistently at this point. Is there a way to script this to run when a View connection is terminated?

Yea, give me just a minute 🙂 on a call, but can try to get you a profile for it

Here ya go @member

This profile simply puts the command here

So just to follow up in case this helps anyone, the logon/logoff issue I think was a coincidence. However the reason the scanner never worked for the end user was that there was a policy in UEM preventing USB redirection for everyone but admin users. After modifying that policy the scanner works just fine for her.

fantastic! good to hear

That will definitely do it 😛 , glad you got it fixed

@member you mean UEM > User Environment > Horizon Smart Policies? Because I am having a issue with USB redirection in general. USB redirection with Direct Connect to the vm works like a charm but from the moment we go threw the connection server we get no suitable devices. USB redirection is enabled on the connection server and no UEM smart policies.

Correct, we had a Smart Policy that had it disabled. There’s a policy in ours called Default Horizon Policy that had the setting in there, not sure if that actually ships with UEM or if the vendor who helped with our config put it in. I assume you’ve added the PID and VID in the UMS and pushed the policy to your clients? There’s some good info further up in this thread.

Continue reading and comment on the thread ‘Help setting up Fujitsu ScanSnap USB scanners with USB redirection?’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base

Ask a question or comment on the above message thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!

Popular Message Threads

Categories & Tags: