Help with installing a zscaler certificate on to UD2 device to get MS Teams working on an IGEL custom partition

Hello Igel Community,

Im trying to install a zscaler certificate on to UD2 device to get MS Teams working on custom partition(off network teams works fine, on corp. network it does not). Could someone nudge me in the right direction?

Learn more, read the entire thread inside the IGEL Community o Slack

Thank you

Here is link for deploying certs from UMS to IGEL OS endpoints.

I have the cert added to ums and have sent the cert to the device. Ive tried a few different file locations but not having any luck. Getting Teams to work.



Okay… So now we need to figure out how MS Teams Linux application (Chromium based) picks up and uses certs.

Here is a link on certs —

We were not able to use zscaler at all. We just ended up using a private ip and a self signed.

Thank You for the info.

Hello @member,

Honestly, Zscaler does some nasty stuff at an OS level, and I am not sure it’s something IGEL OS can even support. I would recommend trying to move Teams into your VDI image and using RTAV (VMWare) or the offloading for Citrix built into the latest Workspace App in IGEL OS 11.04. This would be a better workflow anyways.

Also, please keep in mind that even if it does work, because Zscaler would have to be deployed as a CP it’s something that IGEL cannot provide direct support on, so it would be use at your own risk.

Update- Teams is now working with Zscaler. I had all but given up, went on the road for 2 weeks for work project. Looked into it again when I got back and without changing anything it’s now working. Our best guess is Zscaler made a change on their end. I added our zscaler cert. to /usr/local/share/ca-certificates/

@member Can you share what all you did to configure things for Zscaler? What was the use case, what ZScaler product(s) used, export of XML profile, etc.

I used a custom partition example I found on IGEL community to get teams installed on the OS. We were receiving an error- 202 ERR_CERT_AUTHORITY on our corp network, connecting to external network things worked fine. We whitelisted the teams URLs on our zscaler. This didnt resolve things. We tried adding our root certificate to IGEL OS. This didnt work at 1st. A few weeks went by and its now working, no changes were done on our side. I tested deploying teams to another end point today on another subnet and received the same error until I added our root zscaler cert. to /usr/local/share/ca-certificates/

Continue reading and comment on the thread ‘Help with installing a zscaler certificate on to UD2 device to get MS Teams working on an IGEL custom partition’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base

Ask a question or comment on the above message thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!

Popular Message Threads

Categories & Tags: