Help with USB devices with IGEL UDC3 and VMware Horizon


We are having the worst time with USB devices with UDC3 and Horizon. We are on 10.04.100. We’ve done everything in the readme but we keep getting issues. Any word if 10.05.100 will address USB?


which kind of USB Issues are you facing?

You may try this private with an updated Horizon Client 4.8

The release is available at:

​LX: igel-technology.sharefile.com/d-s69f36c46f1a46f7a

OS: igel-technology.sharefile.com/d-saf44db9f5044dd49


One reproducable issue we’re getting is that USB only works for the first person to log into the machine and then the machine has to be reboot for USB to be recognized again. We had a ticket open with support and they said USB is currently an issue with Horizon. They told us to try 10.04.280 private build but that actually made things worse. Also we are having less reproducable errors with mice than can move the cursor but not click on items. Thanks for the new private build link, we will give that a try.


I had the same USB issue with 10.04.100 where only the first user could pass devices through. Please let me know if the 10.04.310 build fixes this for you!

I’m currently running 10.04.190 on that device and it seems to be a little better but not perfect


Thanks for the info!


I am seeing this also. I noticed that every other login, the USB devices would connect. I have the Horizon client set to restart. If I ssh to the unit and run “ps aux|grep usb” I can see the vmware-usbarbitrator service still running for several seconds after the session ends. With my Nuance Powermics, this keeps running for 12-15 seconds, other devices 3-8 seconds. If the Horizon client starts before this service stops, USB unavailable. If I turn off restart and wait 15 seconds before starting the client, USB works.

Can anyone else verify this? Is there a way to add a restart delay like there is a autostart delay? Or a way to not allow restart until all services have ended?


You could add a postsession command (System=>Firmware Customization=>Custom command) for vmware horizon like killall yourprocess


So killall vmware-usbarbitrator?


Sounds good:hugging_face:


Tried that, still didn’t kill it before the auto restart


Would killall -w 10 or some other value maybe help give it a few extra seconds to wait for it to die?


Try to disable your session restart and then this commands in your terminal

killall vvdmlogin&&killall vmware-usbarbitrator&&pkill -f vmware&&su user -c “/config/sessions/vdm_client0 &”


I’m away from the office for the rest of the day, but will try both those first thing in the morning. Thanks for the suggestions.

I tried killall -w and it just killed the usbarbitrator for the new session, it didn’t pause the client from restarting


We just decided for now to make our machines reboot after users log out of the Horizon session to help with USB.


Private build 10.05.630 finally fixes this issue for us: ### VMware Horizon

Added continuous run mode for vmware view usb-arbitrator.

+————+—————————————————————–+

| Registry | `vmware.view.usb.arbitrator-continuous-runmode` |

+————+—————————————————————–+

| Value | enabled* (default) / disabled |

+————+—————————————————————–+

Continue reading and comment on the thread ‘Help with USB devices with IGEL UDC3 and VMware Horizon’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base



Ask a question or comment on the above messasge thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!


Popular Message Threads


Categories & Tags: