How to capture CDP data coming from our switches using an script?


I am trying to use the attached script to capture CDP data coming from our switches to write it out to a field in UMS. I have to su to the root user when testing it locally for it to work. When I try to run it via Custom Command, the variables aren’t defined. Is there a way to run it with the required permissions from the UMS profile? Also… I am using the structure tag field in UMS as it was mentioned in another example, is it possible to write to a different attribute in UMS?


Usually, commands that are executed as custom command are executed in a root context. How did you start your script in your profile?


I just have the attached script pasted in Initialization section of the profile.


Try another approach for testing:

create a file on your computer

paste your script in it, save it as script.sh

upload it to UMS using files: file location /wfs/script.sh

Rights: RWE for root, E for user

Assign the file to the endpoint

check if file is really there

Change your profile with custom command to

/bin/bash /wfs/script.sh

I tried running it this way as well and I’m getting the same result.

And what happens when issuing the /bin/… command in a local terminal logged in as root?

Continue reading and comment on ‘How to capture CDP data coming from our switches using an script?’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base



Ask a question or comment on the above messasge thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!


Popular Message Threads


Categories & Tags: