How to deploy PKI Root Certificate via IGEL UMS to be used inside the Firefox?

some short question. I am trying to deploy our PKI Root Certificate via UMS to be used inside the Firefox. I did it as Web Browser Certificate (.cer as base 64 )and deployed it to my test client. I am still getting a certificate error on my internal site and cant find the certificate in the Firefox Certificate store. Am I doing something horrible wrong?

Learn more, read the entire thread inside the IGEL Community o Slack

Horrible? No, I can’t imagine that you are torturing your endpoint:face_with_raised_eyebrow:

Can you try it again as common purpose just to be sure?

You could also check the certificate against your site: openssl s_client -connect -CApath /etc/ssl/certs

Which Firmware / UMS are you using?

Thanks for the Answer. I can confirm it is working via CLI. It finds my Certificate and it is valid. But it dose not show up in the Certificate Store of Firefox when I go into the Setup on the Thinclient (Session->Browser->Browser Global->Certificates->ShowCertificates) UMS Version is 5.8.110 and IGEL OS

Ok! Did you tried the common purpose?

by now I have tried any Purpose available. Also with different Filenames in case they overwrite themself.

Sounds weird but can you try to downgrade 10.04 and repeat the procedure?

I think I have figured it out. The Firefox cant handle crt in base 64. I have exportet one pem file foreach certificate and now it shows up in the certificate store of firefox.

The certificates should always be in base64 format.

Continue reading and comment on the thread ‘How to deploy PKI Root Certificate via IGEL UMS to be used inside the Firefox?’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base

Ask a question or comment on the above message thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!

Popular Message Threads

Categories & Tags: