How to force dual monitors to extend to the right vs just mirror in IGEL OS?


How would one go about forcing dual monitors to extend to the right vs just mirror? We get an error when launching display switcher on our HP t510’s with a UDP. A majority of them only have one monitor, so we just force the screen resolution. However, we have some with dual monitors and need to force it to extend to the right without needing to go into display switcher.


Error when launching display switcher is Unable to start the XFCE display settings. Unable to query the version of the RandR extension being used.


Dumb question maybe but are you using Vesa mode? Would be interesting to have the firmware version also.


Firmware is 10.5.500

Not sure what vesa mode is


I Made Some scripts for it.. so did @member so do a quick search for these mods


To keep it simple Vesa mode is a more compatible mode. In addition to the great xrandr stuff from @member and @member you could also try to start the Display Switcher by „hand“. Open a terminal and issue this command: xfce4-display-settings Does it work then?


xrandr –output $EXTERN1 –primary –output $EXTERN2 –pos 0x0 –right-of $EXTERN1 –pos 0x0 something like this..

xrandr -q for the names of the output ports


xrandr comes back stating RandR extensions missing. We could execute xrandr –help and see the commands available, but when running we get that message


In UMS the graphics chipset 1 does say VESA, but I could not see a way to change that in BIOs


@member did you tried also the xfce command sent before?


we don’t have access to the device at the moment. Devan is going to do some testing tomorrow. We had to get the user back up and running, so we had it revert back to HP Thin Pro for now. Devan will be able to test at his office.

@member, Devan didn’t have a chance to test yesterday due to other issues that needed worked on. We will get back to it soon.

I ran xfce4-display-settings and got the same error as when trying to launch display switcher in the gui. “Unable to query the version of RandR extension being used”

now, we do see some additional info in the terminal window: “Xlib: extension “RANDR” missing on display “:0.0”

I do only have one monitor connected at the moment, but wanted to see if it would at least launch


Hold on… Are we speaking about a VIA Chipset maybe? @member


ah, yes it is


No VIA graphic adapter; VIA graphics support is discontinued in IGEL OS.

kb.igel.com/igelos-11.01.100/en/devices-supported-by-osc-and-ud-pocket-10327369.html


thanks. We’ll switch this station out with one that we can do multi-monitor on and then put this one where only one monitor is needed. 😉

Continue reading and comment on the thread ‘How to force dual monitors to extend to the right vs just mirror in IGEL OS?’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base



Ask a question or comment on the above messasge thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!


Popular Message Threads


Categories & Tags: