How to get a OS12 Demo license?

Hi All, I am having trouble with figuring out how to license my PoC end points to be able to install apps from app portal. Any specific guidance? Device currently has a starter license applied. Thanks

Learn more, read the entire thread inside the IGEL Community o Slack

Check out this link here:

You can get 3 full lics for 90day by adding your details.

I’ve done this a few times.. seems like this is license for OS 11 though

You can select the OS version from the dropdown

Which UMS version are you using?

UMS 12.02.100

The unit ID is not matching. You have added the MAC Addresse but the unit ID in your Screenshot is different. The license is targeting the unit ID


i thought it was mac based?

Well usually MAC and unit ID are the same but not in your case

let me try another license with the E on the end


You are Welcome otherwise you can also reset the unit ID, too

You can run the command “get_unit_id” for that

still no workie 😞

I’ve reset the device in the past to factory defaults we well. this is weird.. this stuff used to work super smooth on UMS 6.x with os 11

Is time / date set correctly on Universal Management Suite and endpoint?

time is correct… but the timezone are different. do I apply the license in the legacy UMS console to the device?

Timezone difference is fine. Which license exactly are you trying to assign (screenshot of the packname)? What happens when assigning the license manually from the context menu?

last screen shot I posted shows the error when I try to license the device manually from UMS. I think this is what you’re looking for?

last screen shot I posted shows the error when I try to license the device manually from UMS. I think this is what you’re looking for?

Oh, yes. Sorry. Could you create a lic file, and deploy it locally via the licensing tool, only for testing?

I ca try 🙂 how do I do that

Hope this helps ☺️

I’m on OS 12.. same process as 11?

Yes, should be!

I created a new VMWare Workstation OS 12 machine and that one licensed correctly from UMS. Now I figured I couldn’t download any apps from portal before due to licensing.. I am still getting the same error if I try to install an app from app portal on the new OS12 machine.. In UMS I don’t see any apps from app portal other than Base OS. Any ideas?

Apps and Os12 are only available in WebUMS. Did you follow this steps?

I recommend these documents:

and, if you want to test Apps without UMS:


@member thank you for the links, i appreciate it. I had the UMS registered in cosmos customer portal. I noticed one thing, if I try to open the app portal link from within the web interface I get this error..

even though the device in question appears licensed… still unable to download any apps from the app portal due to licensing apparently

FWIW, i built a new OS12 VM and connected it to the sandbox UMS to demo, and Horizon client and other apps install just fine on the end point. Gotta be something with the licensing

another update.. using a UMS-less licensing solution also allows download on the endpoint.

Got the issue resolved.. had to unregister the UMS registration re-register again in customer portal

not sure why that was needed, but it works now.

Continue reading and comment on the thread ‘How to get a OS12 Demo license?’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base

Ask a question or comment on the above message thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!

Popular Message Threads

Categories & Tags: