How to import the device certificates to the Google Chrome browser CA store running at a Custom Partition?

Hi everyone. Not sure if anyone else uses Google Chrome Browser in a custom partition but I need to import the device certificates to the browser CA store. I have tried using the certutil commands as I have done in Ubuntu Desktop but no luck. This is to import an internal root certificate for the browser. The certificate is already deployed from UMS and exists in /etc/ssl/certs.

Learn more, read the entire thread inside the IGEL Community o Slack

Thanks all

Hi Charlie, which Firmware are you on? I guess using the IGEL OS Builtin Chromium wouldn’t help, right?

I guess the issue is that a command like these:

certutil -d sql:$HOME/.pki/nssdb -A -t “C,,” -n “Webservice” -i /etc/ssl/certs

isn’t working because the nssdb isn’t where the command is expecting it. Please try to issue:

find /custom -type f -name “nssdb”

and adapt your first CLI command as you need. If that work, you could put it as a Final Network command: and reboot.

Hi Sebastien. I am on FW 11.05.133 but also tried 11.05.120. Correct, Chromium will not work. I will give this a try. Thank you for the response.

Sebastien- i was able to get the certutil command to execute by creating a new profile and using that command in a custom application. I disabled the desktop options and just set it to auto start on boot. Adam Woydziak from iGEL helped me get to that point. Thanks to both of you for the speedy assistance and success!

Continue reading and comment on the thread ‘How to import the device certificates to the Google Chrome browser CA store running at a Custom Partition?’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base

Ask a question or comment on the above message thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!

Popular Message Threads

Categories & Tags: