How to initiate a “reset to factory defaults” command from the IGEL OS command line?


Does anyone know to initiate a “reset to factory defaults” command from the command line? I tried installing a firmware and the device is not reachable.


Sure: reset_to_defaults


After installing a firmware, the device is stuck with this message,

the device is not reachable from the UMS. I tried removing the Firmware profile from the configuration and power cycled, but the device continues to try getting the update

any other suggesting before I reset it to factory default

?

Thank You


Did you checked if the device itself has network and could reach the UMS?

Just a few commands if you want to try to pack the update on a usb stick (FAT32), assuming you extracted the update file in the root directory AND that only one Stick is connected:

mkdir /userhome/update

mount -a

mount /dev/sdb1 /userhome/update

setparam update.protocol FILE

setparam update.file.path /userhome/update

hope that helps a bit to get the device recovered!


The device is connected to the network and can be pinged from the UMS…. one thing that we did recently was migrate the UMS from Windows Server to an Ubuntu Server

The database was then restored

Initially we got errors when trying to apply the firmware to the device…somehow the device couldn’t find the firmware file.. we then uploaded a new instance of the firmware (same version) and then it seemed like it worked because it seemed like it was installing. After the reboot however, we lost connectivity


Can you check if you open the local configuration by right click the device, Edit configuration, System, Update, Firmware Update:

if Host corresponds to your new server, if yes, go to the endpoint, terminal:

probeport yourupdatehostname 8443


Didn’t get a chance to further troubleshoot, so I just did a factory reset from the device command line. It’s working now. Thank You

Continue reading and comment on the thread ‘How to initiate a “reset to factory defaults” command from the IGEL OS command line?’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base



Ask a question or comment on the above messasge thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!


Popular Message Threads


Categories & Tags: