How to logon to our AD / IGEL OS desktop and after Citrix self-service autostarts


Hi all,

I’m using an UD3 and logon with AD Credentials to authenticate a user (see screenshots).

Now I use Citrix self-service as the method to access ressources from our Citrix farm (again see screenshot). The reason is that by using the Citrix self-service method the appearance of the Citrix Workspace window is identical to the appearance of Windows and Mac clients etc. . If I use Citrix StoreFront configuration for igOS I don’t have the Citrix Workspace Window, instead the apps are presented on my igOS desktop. The look and feel would be different compared to Windows, Mac, etc. which present Apps in the Citrix Workspace window. So we prefer to use the Citrix self-service method for igOS.

My question is if it is possible to logon to our AD/igOS desktop and after Citrix self-service autostarts I’m SSO to Citrix self-service / Citrix Workspace? Currently I’m presented a second logon window to which I have to authenticate with the same credentials used seconds before (compare screenshot). SSO using StoreFront configuration for igOS is working fine though.


Hi Sven, yes, it should at least. Did you enabled the Passthrough authentification? I cannot check by myself atm. but here is the config:


Hi Sebastien,

thank you for your answer.

Yes, I have enabled the option but I still get the logon prompt. So I thought maybe I’m missing something in the config…?

The screenshot shows the current config but SSO to Citrix self-service is not performed…

I thought so that a SSO with AD credentials is possible but I need a hint how to set it up correctly.


I would rebuild your Citrix Profile and set it up like these (and nothing else): please check also that the Domain youc configured in the Ad Section matches 1:1 the trusted domains on Citrix side. I mean: if it’s there as mydomain.com mydomain.com , login in in the domain mydomain without suffix wont work either. I can’t start my Citrix env. atm. but from I recall it should work this way.


No problem, take your time 🙂.

I tried your suggestions but I’m still getting the logon prompt. Also I tripple checked if the trusted domain is correctly configured at every part (ADC for LB, StoreFront, igOS config) because I read it several times here in the community and elsewhere.

The weird thing is that AD logon and the second logon work with the exact same credentials entered in the exact same manor… so I think SSO should be no problem but it isn’t carried out…


According to the feature matrix passthrough authentication with the Linux Wotkspace app is not supported. www.citrix.com/content/dam/citrix/en_us/documents/data-sheet/citrix-workspace-app-feature-matrix.pdf www.citrix.com/content/dam/citrix/en_us/documents/data-sheet/citrix-workspace-app-feature-matrix.pdf


@member absolutely true, but since we bypassed it on Storebrowse (where it works) I was expecting it working on Selfservice too 😄


@member Hmm, maybe playing with the authentication type helps, I never tried. kb.igel.com/igelos-11.04/en/login-32870917.html kb.igel.com/igelos-11.04/en/login-32870917.html


Hi all,

thank you @member for the info. I should have looked that up myself.

According to the feature matrix it is obvious why SSO is not working (at the moment).

I tried different authentication types but it didn’t work. So I guess the road ends here 😐

Also a big thank you for @member for your support!

Continue reading and comment on the thread ‘How to logon to our AD / IGEL OS desktop and after Citrix self-service autostarts’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base



Ask a question or comment on the above messasge thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!


Popular Message Threads


Categories & Tags: