How to permit the user account to start an update from the terminal on IGEL OS?

I am writing a script that runs in the background under the user account that, among other things, updates the firmware. However, when I run /bin/update, it says ‘Error: Update is not permitted.’ Does anyone know how to permit the user account to start an update from the terminal?

Learn more, read the entire thread inside the IGEL Community o Slack

I have questions first: which firmware are you using? Second did you attached a firmware file (through UMS Universal Update a.e.) first before trying?

10.04.100 is the one that I am trying to upgrade to. The current firmwares vary, but the minimum is 10.01.310.

The firmwares are applied to the thin clients, and the upgrade works if I run /bin/update as root.

Would you mind to share the script, if not public as PM?

I just checked it, the update process needs to run in a root context (which makes definitely sense), but some tested tweaks didn‘t change that security behaviour. You could go another way and use systemd schedule like described in our github under Compare:

Thank you, that does look helpful. I was hoping to have only one script running, instead of multiple ones, since that is easier to track. I was also hoping for the script to run as a user, since most of what it does is only for the user (such as running a session). What is odd to me is that there is a ‘firmware update’ ‘application’ that can be enabled for the user to run from the menu.

I traced it a little more, and might have found something… Enabling the firmware update application for the user menu adds /usr/share/applications/firmware_update_000.desktop.

This file runs ‘appwrap firmware_update0’.

That file runs /config/sessions/firmware_update0.

In turn, it finally runs /config/bin/firmware-update.

If I run /config/bin/firmware-update as a user from the terminal, it updates the firmware as I want.

Ok, let me check that!

Continue reading and comment on the thread ‘How to permit the user account to start an update from the terminal on IGEL OS?’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base

Ask a question or comment on the above message thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!

Popular Message Threads

Categories & Tags: