How to redirect a Scanner in AVD on IGEL OS?

We are trying to passthru a USB scanner into AVD — The IGEL thin client recognizes the USB device (see entry in kern log) but it does not appear to try and pass that into the AVD sessions. Is it absolutely required to use Fabulatech for USB scanner redirection, or can it be done without?

Learn more, read the entire thread inside the IGEL Community o Slack

I have added the VID and PID to USB allow in both Devices and RDP in the configuration

Fabulatech is the way to go tbh. Are you using USB Access Control on IGEL OS ? If so could you turn it off?

Which firmware version are you using?

We are using USB access control since we are required to block/restrict USB storage devices from all endpoints — using 11.08.360

Please try to turn it off during testings, to avoid false negatives. PLease also try 11.08.440.

Updated to 11.08.440 and disabled USB access control for testing, it’s still not redirecting the scanner into the VM

I also updated RDP USB redirection to default Allow for testing, same result

Does any device get redirected? What does the Fabulatech Server component tell?

We arent currently using Fabulatech, we are trying to determine if it is absolutely necessary. Will no scanner redirection happen without it?

This is correct, Fabulatech is the only way to get devices redirected:

great, we’ll reach out to fabulatech. appreciate it

Continue reading and comment on the thread ‘How to redirect a Scanner in AVD on IGEL OS?’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base

Ask a question or comment on the above message thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!

Popular Message Threads

Categories & Tags: