How to reset IGEL DeviceID to the original value?

Having a bizarre issue with two of my UD-Pockets running 11.01.130. Two work perfectly, the other two changed their DeviceID to match the MAC address of the machine that they booted on and so they are unusable because the UMS sees them as the same device. Is there any way to reset DeviceID to the original value?

Learn more, read the entire thread inside the IGEL Community o Slack

Hi @member, this issue can be solved by executing the following command, which will re-issue the unit id.

get_unit_id -i -f

Is that what you meant?

I don’t know, I’ll see if it fixes the problem and let you know.

You may also need to reset to factory defaults, but try the above command first..

Already did the factory defaults thing, didn’t fix it. I’m booting the troubled pockets now

I think it was the same for me. Eventually somebody let me know about the unit_id reset command and it did the trick for me

Alright, did it and removed the contents of /wfs, rebooting now and we’ll see what the console picks up.

That worked, thank you very much, I was worried I’d have to RMA both of them.

Great to hear! Glad it worked for you


We’re just beginning our iGEL deploy, so I’m glad I have my test units back

Continue reading and comment on the thread ‘How to reset IGEL DeviceID to the original value?’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base

Ask a question or comment on the above message thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!

Popular Message Threads

Categories & Tags: