How to start Firefox in IGEL OS 11 always in a maximized window but not in fullscreen?


Hi, does anyone know if it is possible to start the integrated Firefox in OS 11 always in a maximized window but not in fullscreen? I would like to have a FF window spread over the whole screen but I would still like to see and use the taskbar and start menu.

Learn more, read the entire thread inside the IGEL Community o Slack

Cheers

Michael

Hm, I think I found at least a workaround: Configured the Task bar to always stay on top. It overlays the lower part of the browser windows that way but at least it is visible. If anyone got an idea on how to maximize (not fullscreen) Firefox I would still be grateful πŸ™‚


Hi! I have an idea but Iβ€˜m on a business trip atm. Dumb workaround, I remember that this setting was stored in the Firefox profile somewhere in prefs.js (pretty sure, but canβ€˜t check). If that itβ€˜s the case sed the file in a profile would work OR tweaking with xdotool would be my second thought.


This might be a bit over engineered:

Goes to Custom Commads > Base > Initialization

(Update 2020-03-05: corrected the path in line 5)

cp /services/fbrw/bin/firefox_preferences /services/fbrw/bin/firefox_preferences_

cat > /services/fbrw/bin/firefox_preferences <<“EOF”

#!/bin/sh

/services/fbrw/bin/firefox_preferences_ “$@”

cat > /userhome/.mozilla/firefox/browser0/xulstore.json <<eof

{

“chrome://browser/content/browser.xul”: {

“main-window”: {

“screenX”: “0”,

“screenY”: “0”,

“width”: “1280”,

“height”: “935”,

“sizemode”: “maximized”

},

“sidebar-box”: {

“sidebarcommand”: “”,

“width”: “”

},

“sidebar-title”: {

“value”: “”

}

}

}

eof

EOF

But @member is right, if you put this effectively into prefs.js

“`user_pref(“extensions.igkiosk.browser.start_maximized”, true);“`

I’ll leave this as home work πŸ˜‰

Update: the user_pref method actually does not work anymore for firefox68


Thanks a lot Jo! πŸ˜€

I have just successfully tested the approach with the script. Just hope the solution survives the next firefox update…

Would be even better if Igel adds a checkbox for this setting in the config profiles 😁

@member Hi Jo. I’ve just updated my test client to 11.5 and the script that starts the Firefox window maximized seems not to work anymore. You don’t happen to have a new version at hand already? 😬😬


Actually there is now:

cp -v /services/fbrw/bin/browser_config /services/fbrw/bin/browser_config_

logger “Patching browser_config to start Browser maximized”

cat > /services/fbrw/bin/browser_config <<“EOF”

#!/bin/sh

/services/fbrw/bin/browser_config_ “$@”

sed -i ‘/firefox_preferences/a( while ! wmctrl -r “Mozilla Firefox” -b add,maximized_vert,maximized_horz; do sleep 1; done ) &’ /config/sessions/browser[0-9]*

EOF

Firefox gets increasingly picky about the way you can “reconfigure” it. It just won’t take your changes and reuses it’s own cached versions.

The patch goes to same place as the old one, btw


Thanks for the quick response! πŸ˜ƒ

But when I apply the script to my thin client it shows only a black screen after boot.

Am I correct that I take the code and replace the code from before completly with it?

Clear the red box and paste your new code inside ?


Yes, it’s meant to replace the old patch with the new.

But strange, I tested it here and copied it directly from the slack entry to the UMS field and it worked as it should.

Are you sure the line with the sed command is in one line only?

That is, the whole sed command should be in the last but one line and in the last line there’s only the EOF at the very beginning and nothing else.

(Btw I made a small change at the end of the line with the sed command: `/config/sessions/browser` -> `/config/sessions/browser[0-9]`

that way only the usual browser session starters can be affected by the patch)

In the following screenshot I skipped the logging command. That way the whole command fits in the UMS entry.


@member Hi Jo! It works!

I think there was a copy&paste error on my end or an obsolete line break as you suspected.

I copied line by line in a text editor and then everything into the UMS and now it works!

Thank you very much for your help!!


Very well! The idea of wrapping the browser_config was to mimic the lost start-max. functionality. That is we have to use the external wmctrl command to force the browser maximized because it wouldn’t let us do it directly. But when the wrapping fails, none of the browser start scripts are generated and thus you got the gaping black screen, I presume.


Works for me (11.05.100)! Thanks @member

Continue reading and comment on the thread ‘How to start Firefox in IGEL OS 11 always in a maximized window but not in fullscreen?’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base



Ask a question or comment on the above message thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!


Popular Message Threads


Categories & Tags: