How to test a local USB Ccanner on the IGEL OS?


Hey folks, is there any way to test a local usb scanner on the igel os ? It shows up in system config and i have native usb redirection on and allow as default behavior for citrix. The scanner shows up in citrix and seems to have installed correctly but it will not do anything when i try a start scan or use some other tool to scan. HDX monitor says my scanner virtual channel is missing but I have twain redirection turned on as well so it makes no sense. Im trying to figure out where in the process this darn thing is not working, There are no events in event viewer or error messages when i try to use it in citrix.


Scanners are tricky – I would first try setting native USB redirection to default deny (and it would be best practice to keep it on deny… redirect devices natively only if there’s no other option) and then enabling SANE support under System > Firmware Customization > Features.

If that doesn’t work, go back to your Native USB settings and create an ‘allow’ exception using the specific PID/VID of the scanner and then install the scanner drivers within the VM. You probably won’t see a scanner virtual channel in HDX monitor when you do this, as you’re pretty much just passing raw USB data and not using any sort of specialized virtual channel


Hey Paul, if a local use is an alternative you could try to use my Custom Partition for Xsane:

igelcommunity.slack.com/archives/C8GP9JHQE/p1590583715242600


thanks gents I will give both a try today and see what i come up with

Good morning Gents, so Im using a Cannon DR-C225 for testing its under untested on the SANE list. None of the methods Josh suggested worked.

The printer does show up correctly when I do the second step which is specifically allow the vid and pid of it but its still not usable. Even with that SANE option checked That was where I was in the first place when I reached out to the slack channel. Does anyone else have any suggestions? I will test Sebastians idea in the meantime but its not a solution for the client just a solution for me to test to see if it even scans in igel.

I have now tried another scanner a cannon DR-M140 which is listed as good under the SANE List. Again I have to create a vid/pid rule to get the scanner to be seen in windows, twain isnt working but a new issue crops up. When I try start scan from devices and printers it says it is missing its WIA driver but the windows image acquisition server is running and the proper drivers for this scanner are installed so nice change but still dead in the water with scanners in citrix


Just trying to bring some additional Light in that topic:

1) SANE has primarly to deal with the local IGEL OS, and wouldn‘t bring an advantage on using USB Redirection where the device is virtually speaking unplugged from the endpoint but plugged „into“ your TS.

2) Sane only means, that the scanner would be recognized locally. Nothing more.

3) Sane has to be pulled by local tools like the Custom Partition sent before. Then you could scan (locally) into a folder (like a network path or mapped directory to your TS).

Hope that helps a bit.


Thanks Sebastien I realize that I was just hoping perhaps something hidden in that feature flag would help us and that sane compatibility might indicate compatibility with redirection. Dead in the water on this for now.

Continue reading and comment on the thread ‘How to test a local USB Ccanner on the IGEL OS? ‘.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base



Ask a question or comment on the above messasge thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!


Popular Message Threads


Categories & Tags: