How to turn an SSH command into an IGEL Custom Application?

I want to put an Icon on the Igel endpoint’s desktop that runs a certain command: ssh -X -C -i /wfs/id_rsa igelrmuser@ums “/opt/IGEL/RemoteManager/”

Learn more, read the entire thread inside the IGEL Community o Slack

This command will fire up a UMS Console via ssh-x11-forward, run remotely on the UMS server itself (inspired by @member’s great post This command works fine when I run it from a Terminal app on the Igel endpoint.

But I want to make it an app on the Desktop, to save the person having to open the Terminal app and type a command. So, I defined a Custom Application, with the above command. But when I click on the icon, nothing happens. I see an error-message in syslog: ssh_askpass: exec(/usr/bin/ssh-askpass): No such file or directory. Which is odd, because I don’t get this error when I run the same command from a Terminal.

Any ideas how to turn an ssh command into a Custom Application?

Maybe something like this… –> /usr/bin/xfce4-terminal -T “X11 UMS” –geometry=80×10-0+0 -x ssh -X -C -i /wfs/id_rsa igelrmuser@ums “/opt/IGEL/RemoteManager/”

@member nothing seems to happen, according to logs I’m getting an Access Denied on xfce4-terminal, and indeed, “user” has no rights:

-rwxr-x— 1 root xterm /usr/bin/xfce4-terminal

There must be a way to run a terminal app as user… seems so trivial 🙂

@member you wrote earlier that you created a custom application like:

xterm -iconic -e ‘/wfs/’

When I put the same in the window above, on 11.04.240, nothing would appear when I click on the app’s icon on the desktop and syslog would say: xterm, access denied. And it’s true, “user” does not have access to xterm on the filesystem.

What am I missing, how did this work for you?

@member or, to be more precise, does the above work for you on Igel OS 11.04.240 still? Maybe it worked on an earlier osver, when you wrote it a few months ago.

Yes, that is correct. As part of better securing IGEL OS the xterm application can only be run with the root permissions in later versions of the OS

Here you go: Steps to setup and a quick demo.

@member I see that you defined the custom app in the local Setup while I was doing it on the UMS Server, so to be on-par with you, I removed all custom apps for this host on the UMS and defined this single custom app in the local Setup of the host, with the exact same command as yourself. The icon appeared, the result was the same, though, see in /var/log/syslog:

appwrap[14298]: Starting custom_application0 as systemd service

systemd[7876]: Started UMS Console.

UMS Console[14304]: /config/sessions/custom_application0: 2: /config/sessions/custom_application0: /usr/bin/xfce4-terminal: Permission denied

# ls -l /usr/bin/xfce4-terminal

-rwxr-x— 1 root xterm 244288 Nov 16 15:48 /usr/bin/xfce4-terminal

# grep xterm /etc/group


It will work the same from UMS… I’m on 11.04.240

I’m on 11.04.240 as well… do you have the same results for

ls -l /usr/bin/xfce4-terminal

grep xterm /etc/group


I will have to test it on the newer Versions of Firmware, I hope it is not Broken as we will not be able to move forward with newer Versions of Firmware till we create a work around. I am out for a while but will see if it still works or not for us.

Continue reading and comment on the thread ‘How to turn an SSH command into an IGEL Custom Application?’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base

Ask a question or comment on the above message thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!

Popular Message Threads

Categories & Tags: