HP Laptops convered to IGEL OS lose config when undocking from USB-C docking station

Hey guys. I have a few HP laptops that are using the HP USB-C docking station with two montiors. We can get everything setup correctly but then it loses its config when undocking. When the laptop is redocked it only shows display on the laptop screen. We are using the display switch to configure the setup and I have confirmed that the option “Preserve settings over reboot” is check. Any solution to this?

Learn more, read the entire thread inside the IGEL Community o Slack

Hey Shanna, did you also checked: Configure new displays when connected ? If not, can you do so please and re-test?


which firmware are you on?

and do you by chance know if the docking station uses a usb-display adapter or alternate modes?

If you don’t know for sure, can you paste the output of `xrandr` or `get_drm connectors` while connected?

Is it a G4 station?

@member you took the words out of my mouth 😄

www.youtube.com/watch?v=_wO8toxinoc :rolling_on_the_floor_laughing:

So I have a few users having this issue. I will investigate exactly what each one is using as far as connection but this is what I have for one user:

HP USB-C universal docking station: Y0K80AA#ABA

Although she has a USB-C port on her laptop, Igel does not detect it so she is using the USB adapter to plug in.

Firmware version

OK so that is the store.hp.com/us/en/pdp/hp-usb-c-dock

Did you try and enable the Interface 2 in the profile?

The G4 is slightly different.. store.hp.com/UKStore/Merch/Product.aspx?id=3FF69ET&opt=ABU&sel=DEF

Correct @member.

@member are you talking about the LAN interface?

for the G4 there will be a FR from :flag-ch: soon

@member exactly

@member were you able to check this:


xrandr would be helpful here

@member yes, the network port and usb ports work fine. Its just the displays that are not holding config

@member user is away from computer. Are you just wanting to know what cables are plugged in for the display?

no, I wanted to see how many displays are recognised. xrandr will give a list of connectors and the connected monitors. I’ve worked with HP USB-C docks before with another customer and we were able to get it working by forcing the screens with xrandr

In their situation the users were at desks and there wasn’t so much an issue with changing configs. But I do remember that the config was lost if they disconnected and reconnected

@member see attached

Looks like you have two monitors connected via DVI on the Dock, is that right?

I just noticed that is says DVI, but not, one is a HDMI and one is a display port.

# get_drm connectors

edp1 dp1 hdmi1 card1-dvi1 card1-dvi2

thanks, are they straight cables or are they converter cables? E.g. DVI to HDMI

Straight, no converters

OK so those ports must be being recognised wrong on the device because they are both coming up as DVI

Any way to force them to the correct?

I don’t know about that. But to force the monitors to come up again I could make a command for you. Do the monitors appear inside Display Switch after reconnecting the dock?

No. It takes messing around with resolution to get them back up. So if one does not come up, I will change the laptop resolution to automatic. Once that is done, I will go back and change it to the correct resolution for the laptop and everything works, even after a reboot.

And now that I think about it, all of these devices that are using the dock are showing the displays as DVI.

Ok, try this command:

“`xrandr –output eDP –off –output DVI-I-2-2 –primary –auto –pos 0x0 –output DVI-I-1-1 –auto –right-of DVI-I-2-2“`

That will deactivate the laptop screen, by the way

I will try it now!

Applied to computer in test environment. It worked however, once the laptop was undocked and then redocked the laptop screen and 1 monitor works and they are mirrored (which is uncheck in display switch). Other monitor is not showing up. Also, display switch only shows the laptop monitor as connected and not the other two monitors.

Update: while computer was docked, I rebooted the machine. All monitors (including laptop) but they are mirrored.

Right ok. To be honest I didn’t expect it to keep working after a reconnect as that command is non-persistent

If you have a particular setting that you want to apply at boot, that’s not too hard. But getting it to react to connection of monitors is more difficult and is something which would probably have to be raised as a Feature Request

As some additional info, would it be possible to do the following:

• disconnect the USB-C dock

• run udevadm monitor

• reconnect the dock

and post the output of that.

This will tell us what system device is coming up when you connect the dock.

# udevadm monitor

monitor will print the received events for:

UDEV – the event which udev sends out after rule processing

KERNEL – the kernel uevent

Once dock is connected:

@member this is what shows up on the screen…

@member is there a way to put this command as a shortcut on the desktop for the end user to run when they dock? Maybe that is the best work around for now.

Hi @member yes, definitely. I was looking into how easy it would be to have this automated 😅

You can add a command as a Desktop shortcut by going to System > Firmware Customization > Custom Applications – if you need me to adjust the command for certain use cases, please let me know!

I actually just figured that out and deployed it. I changed the settings around as the monitors were backwards. Works like a charm! Thanks SO much for all of your help!

See, you don’t even need our help! 😀 You should come work for IGEL!! 🦔

Ha! You guys would be highly disappointed.

Hi @member, we are new to Igel and it looks like w’ve got the same ‘problem’ with our laptops and dockings. Could you share your solution to me. Thanx

Hi Ad, the solution which worked for Shanna can already be found in this thread above. But, as mentioned, the xrandr command must be modified for your exact monitor names. You can find more info about xrandr here: linux.die.net/man/1/xrandr

Ok, I will have a look at that.. I’m not very into Igel/linux yet, but learning more and more..

Continue reading and comment on the thread ‘HP Laptops convered to IGEL OS lose config when undocking from USB-C docking station’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base

Ask a question or comment on the above message thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!

Popular Message Threads

Categories & Tags: