IGEL Custom Partition Error: (myapp:23407): Glib-GIO-ERROR **: 16:12:21.255: Settings schema ‘myapp’ is not installed.


Hello, i created my first CP and i have an issue with my custom app.

I am able to deploy it to the thin client. I get the correct icon on my desktop and it is mounted under /custom/myapp

when i start it manually by going into /custom/myapp/usr/bin and starting it with ./myapp i throws an error:

(myapp:23407): Glib-GIO-ERROR **: 16:12:21.255: Settings schema ‘myapp’ is not installed.

i found a folder containing this schema /custom/myapp/usr/share/glib-2.0/schemas

does that has something to do with the initialisation of the custom partition going wrong?

if i run the customization manually (the same as in the UMS parrameters) i receive no errors, except for 3 files that already exist. Is there some kind of log file where i can see what the “myapp init” does?


What is the application?


Hello Peter, I would rather expect your app linked into

/usr/bin

by your initscript or are you doing it differently? I would start it from there


Right… key is the init script to link it into the IGEL OS readonly filesystem. See this example:

github.com/IGEL-Community/IGEL-Custom-Partitions/tree/master/CP_Source/Unified_Communications/Microsoft_Teams


i’m trying to get eid-viewer to work. So i extracted the eid-viewer and its dependancys in a Linux workstation and altered the example from Ron Neher’s Microsoft Teams


so you have the init script from Teams updated for your application… right…


yes, that’s correct

well, if you mean the custompart-teams file, yes

or which one do you mean?


did you check for any missing libs… ldd on the executable

As noted in readme here

github.com/IGEL-Community/IGEL-Custom-Partitions


ok, i see, the content of your “teams-cp-init-script.sh” is the one i used for my app


ldd <file_name> | grep ‘not found’

yes

it links the CP into IGEL file system


so if i open up a terminal on the IGEL i should see it under /custom and user /usr?


Yes… the init script — here is the key code to link it in


ok, that is what i used, i did not change that port, only the upper part of it


So, in the profile… you will have init script with init

See line 29 in profile XML

github.com/IGEL-Community/IGEL-Custom-Partitions/blob/master/CP_Source/Unified_Communications/Microsoft_Teams/teams-profile.xml


<ivalue classname=”custom_partition.source%.init_action” variableExpression=”” variableSubstitutionActive=”false”>/custom/custompart-eid init</ivalue>

is from my profile file.

i did not use the .sh in my name but i think that is ok?

i’ve send a screenshot from what i altered in the init file

the executable is in /usr/bin


If .sh is in the file name… then it is needed.

you can open a terminal window as root and run the init script with init


if i use the terminal on the IGEL, where can i find for example the Teams app that is working fine. Under /custom or should i be able to find it in the normal folder structure


then you should see it linked in IGEL filesystem.

Please note that you can ONLY have one CP deployed… if you have multiple CPs … you combine them all…. Let me get a picture of that from my UMS


i currently have 3 CP’s ! one for VLC, one for Teams (yours) and one with my eid-viewer software


i have 3 different profiles

so i should merge them all togheter in one profile, right?


YES!

see the screen shots above…


ok, and after that, i can test again and see if i still receive the same error, correct?


correct….


nice!

but if i remove all other CP’s on the IGEL and only push my eid-viewer it should work?


Yes… that is how I do it to test….

Then I combine

and re-test.

When I do a new package, after I deploy it… I check that the init script links it all into IGEL OS filesystem, then I check with ldd on executable that we have no missing libs (ldd <file> | grep ‘not found’

If I find any missing libs, then I go back and get them and re-build tar.bz2 with them

That can be seen in the build script — for example for Zoom it is missing libxcb-xtest0

github.com/IGEL-Community/IGEL-Custom-Partitions/blob/master/CP_Source/Unified_Communications/Zoom/build-zoom-cp.sh


wow ! this is really usefull info! thank you very much! i’ll read through these instructions and start re-testing! Thanks!


IGEL Disrupt … Are you attending? I have put together some slides and 3 videos that go over all of this… Also IGEL Academy — If you have a subscription you will have access to my ICE pack for Custom Partitions that goes into detail on this…


Yes! i’m already registred! looking forward to it!

I’m going to check IGEL Academy too.

Hi, one more question, can i see the logs from the init in the IGEL logviewer?

@member and i found how to fix my error with my eid-viewer

when i execute this on the IGEL it is fixed:

“`sudo /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas/“`

can i automate this somehow via the profile on the UMS or…


remove the sudo and put that into your init script

Continue reading and comment on the thread ‘IGEL Custom Partition Error: (myapp:23407): Glib-GIO-ERROR **: 16:12:21.255: Settings schema ‘myapp’ is not installed.’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base



Ask a question or comment on the above messasge thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!


Popular Message Threads


Categories & Tags: