IGEL OS And Teams Optimization


Hello! Apologies if this is not the correct place to post this, but we have run into an issue and wondering if there are any solutions.

Learn more, read the entire thread inside the IGEL Community o Slack

We have a deployment with iGEL + Citrix + Windows session hosts with HDX optimisation. Microsoft Teams works with audio devices and webcam via the remote session, but the noise suppression options are removed when using Teams with VDI optimisations enabled. Apparently, this is because when using VDI + HDX optimisation, Teams runs in WebRTC mode like it would do when using a browser session. Disabling Teams VDI in the session options in UMS does return the noise suppression options in Teams, but the webcams no longer show a video stream – just a black video feed.

Does anyone have any solutions which would allow both noise suppression and webcam video to work simultaneously? Any assistance is much appreciated.


Hi, I assume you followed this guide, right?

files.igelcommunity.com/igelos_ucc_guide.pdf files.igelcommunity.com/igelos_ucc_guide.pdf

Not sure if noise and echo are going in the same direction: igelcommunity.slack.com/archives/C8GP9JHQE/p1643830744747559?thread_ts=1643713643.653389&channel=C8GP9JHQE&message_ts=1643830744.747559 igelcommunity.slack.com/archives/C8GP9JHQE/p1643830744747559?thread_ts=1643713643.653389&channel=C8GP9JHQE&message_ts=1643830744.747559


I hadn’t tried customising the HDX settings using these json options – I will give this a go, thank you.

Interesting, I can’t see the log entry that confirm the settings have taken effect after applying. I can see that the OverrideSettings option takes effect, but after restarting Teams and completing a call, I never see the “webrtcapi.NavigatorUserMedia” appear in the log. I did all 3 EnableXXX options into the json file and kept them on one line.

I can only see this in the log when using ‘OverrideSettings’


Hem, weird. which firmware?


11.05 – Quite a few versions out of date it seems. I’ll get thisupdated and try again

And after an update – it’s there. Thanks so much!

Continue reading and comment on the thread ‘IGEL OS And Teams Optimization’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base



Ask a question or comment on the above message thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!


Popular Message Threads


Categories & Tags: