IGEL OS “cannot connect to remote management”, can’t edit / send commands/ update devices from UMS


Hey there, i am testing an UD3 with IGEL UMS. auto register works great, but i cant edit / send commands/ Update with igel ums. When i restart the thinclient localy, at reboot he knows my changes and aks me if i want to aplly them?!

There are no firewalls set. straight thinclient and igel ums in one subnet… what could it be? the tc is showed as online all time in the UMS, also the autoregister worked automatic with dhcp…

it says all time “cannot connect to remote managment”


i would expect port <tel:30005|30005> tcp blocked from UMS to endpoint. is there a Antivirus on that server?


hi, i am using igel ums on a virtual debian 10 machine. no ports blocked, “all open” for testing purpose. also the firewalls are “open”. bit i’ll check it, maybe a little setting is broken

there is no antivirus


Debian isn’t directly supported. You may be running into a small quirk. Maybe reinstall on Ubuntu 20.04 LTS and see if it corrects the issue?

myigel.biz/public/IGEL_UNIVERSAL_MANAGEMENT_SUITE/LINUX/Readme%206.06.100.txt?forcedownload


sorry it was ubuntu, my fault. my second machine was debian. i am now trying on a windows server machine

alright, same problems. maybe the network isn’t correct, i’am not smart enoguh but it just wont work in this situation.


Easiest way (and you are for sure smart enough😌✊):

from your Ubuntu UMS, in a Terminal:

probeport IpOfYourClient 30005

or

nc IpOfYourClient 30005

Does it states successful?


i’ll setup a complete new setup in a virtual environment and check it. i cant believe, that it wont work

i’ll try it!

<connectionstate><response>value=<OK></response><protocolversion>value=<8></protocolversion></connectionstate>

both clients. i cant add those to ums.


What IP stands under:

System, Remote Management? when right clicking the device and edit configuration?

If the device sees the new UMS, and works after a factory reset, I suspect the certificate.

On a local terminal:

journalctl -f | grep igelrm_agent

and send a new config. What does the logs tell?


So: I found the problem…. took me 2 days, but okay, selfmade problem.

Maybe for some other people related:

i placed the UMS as a VM in my datacenter, strapped a OpenVPN Site to Site to a outstanding firewall (my office ). My fault was, that there were “NAT Outgoing” settings set…..

So the path to the UMS went well, but when the TCP pakets went pack to the TC the pain started.

After correcting NAT Outgoing now it works like a charm. firmware updates very well. also the UD Pocket works nice!

UMS is running in a ubuntu 20 qemu-vm solid.

thanks for your time! the hint to check the tcp connections went my thoughts on the right path 🙂 i think

Continue reading and comment on the thread ‘IGEL OS “cannot connect to remote managment”, can’t edit / send commands/ update devices from UMS’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base



Ask a question or comment on the above messasge thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!


Popular Message Threads


Categories & Tags: