IGEL OS connection errors “This connection has failed. Please check the settings.”

Hi, our Team has experienced an ongoing intermittent issue for some time now from Version 11.03.110, 11.03.500, 11.03.580.01. The laptop is unable to connect to any of the surrounding WiFi Networks available that are known to the user, the error presented after inputting the network key is “This connection has failed. Please check the settings.” I searched this issue prior to sending this message and only found one thread similar, but it only relates to an iPhone HotSpot with an apostrophe in the SSID. This is not the case for us as this continues to happen in multiple environments attempting to connect to multiple Modem/Routers. The most recent occurrences are the inability to connect to an Xfinity Modem/Router and a UniFi AP. Any tips and/or suggestions are greatly appreciated!

Learn more, read the entire thread inside the IGEL Community o Slack

What wireless card is in the laptop? Did this happen prior to 11.03? Have you tried enabling the backport drivers?

The two screenshots below indicate two separate locations with the backport driver set differently

This is what I found under the specs online with the laptop’s serial number

Is there a better way to find the wireless card info via the UMS?

I’m new to IGEL so I’m currently helping my Supervisor on the matter so I’m not sure if the company was ever on a version prior to 11.03

before we look at model of the card, let’s explore your two screenshots. Are those screenshots from two different endpoints, two different profiles, or a mix? The one on the left looks like it is from an endpoint (laptop), but the one on the right could be from a profile or endpoint. The lock symbol in the settings on a device means it is set by a profile.

This is how we have our Wireless profile setup. In addition to this, we have another profile that disables the backport drivers that we apply to laptops that don’t work with the backport drivers.

The screenshot on the left is where the laptop with the issue currently sits and has a profile assigned to the folder it’s in which has the setting set to ‘False’ for the backport driver. The screenshot to the right is from the profile and folder it used to sit in with the setting set to ‘default’ (I may have grabbed a screenshot from a specific machine opposed to the profile it used to sit in, but settings were set the same as the screenshot….hope that makes sense)

We also have another wireless profile setup with the same settings you mention and then a subfolder with a profile assigned to it to disable the backport driver. Whether the laptop in question was in the subfolder disabling the backport driver or out of the subfolder with just the wireless profile assigned to it, neither was working and we were still unable to get connected to the WiFi

Hmm, reread your initial post. I think I had my brain going in the wrong direction. If the wireless manager is coming up, then it likely isn’t anything to do with the backport drivers.

I’m using unifi APs at my house and haven’t had an issue with the five laptops I’ve tested with. That, in addition to it not working at other places, likely isn’t the issue. I did have an issue once where I had to remove the wireless settings and reapply then to get it to work. Also, have you tried factory resetting the device and having the profiles reapply?

Would this screenshot be what you’re referring to when you say to try factory resetting the device?

If so, I don’t have any experience doing this, so any additional info or precautions you know I should take would be great?

Is this a device that is actively being used by someone?

Yes, it’s a user who works remotely, even prior to COVID. So it’s not as easy as we’d like to get our hands on phyiscally if need be

ok, so factory reset probably wouldn’t be the best thing to try at this point. That does make it a little more difficult for you to test things for sure.

Is this the only machine you have this issue with? If so, do you have others of the same model that do work?

It’s the only one I’m currently dealing with, but there has been more occurrences with other machines as well

so it is just randomly happening? Like where it was working and just stops or it just hasn’t worked at all?

Yes, it’s random and intermittent, but when it occurs there’s no getting around it

Rebooting has helped on some occasions, but it doesn’t seem to be a legitimate solution

yeah, definitely not a good solution. It’s what I call a “level 1 support solution.” It is fine for an extremely rare issue, but not a recurring issue. Level 1, at least in my experience, just wants to get the ticket cleared and not really caring about preventing the issue in the future.

are the devices having the issue the same model?

Correct! All the laptops are the same model: HP ProBook 455 G6 Notebook PC

it appears that model had the option of two different wireless cards. I am wondering if the 16.04 kernel had the drivers for them or maybe there is an updated driver that 18.04 would contain for it.

Hmm, seeing some issues with others online running ubuntu kernel 16.04 and random wifi connection issues with those cards and others that use the same driver. However, I am seeing others mention that going to 18.04 they get no wireless card found, which makes me wonder if you will see that when going to IGEL OS 11.04.100. Some have mentioned an updated driver to fix it on both 16.04 and 18.04. Might be worth opening a case with IGEL to have them look at it. I know that’s not the easiest thing with these being out in the field, but might be the best option.

Ok. I’ll see what I can do. Thank you for all your input and research

Continue reading and comment on the thread ‘ IGEL OS connection errors “This connection has failed. Please check the settings.” ‘.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base

Ask a question or comment on the above message thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!

Popular Message Threads

Categories & Tags: