IGEL OS Creator for Windows – receive syntax error when assigning profiles to the target machine


So i’m testing out the IGEL OS Creator for Windows. So far its looking good till I assign the profile to the target machine. That’s when i get a Syntax error in source URL. I can take the URL from IGEL and post it in Chromium and it pops up asking for the username / Password. I put that in and it loads fine. So not sure why i’m getting a syntax error on the url.


Can you share the whole line of the Iso path?


10.125.10.80:9080/ums_filetransfer/


Are you sure you use 9080 and not 8443 now for file repo?


I get the same when it try 10.125.10.80:8443/ums_filetransfer/ or 10.125.10.80:8443/ums_filetransfer. When i tried to load https into a browser then i get a error that its not secured so thats why i tried http on both.


I always use a FQDN


Carl with or without the 8443?


With

Actually 9080

carlwebster.com/learning-the-basics-of-vmware-horizon-7-12-part-4-controlup-and-igel-overview/ carlwebster.com/learning-the-basics-of-vmware-horizon-7-12-part-4-controlup-and-igel-overview/


Thanks. I tried the full FQDN with both 8443 and 9080 and still get the Syntax error.


can you try replacing your ums ip by ‘igelrmserver’ ?


Still having no luck on this one. I dont have any trouble with Firmware updates so not sure what the issue is. The firmware update use HTTPS protocol and i tried the same. Still nothing. Going to work with my network team but im still stumped on this one.


Can you please export the profile and send it over to me as PM?


PM sent

So this is still a issue. Working with a couple of people. But if anyone has any idea not listed. Please let me know


I know your error, the filename is wrong, you have to change it from osc.iso to the correct one

You can easy check that, when you type in the full url in your browser or the url without the file name


Yep, and make sure when you click the iso in the browser, that it downloads


I went in a deleted the profile. Tried again with Lars suggestion and still getting the same error Tried both HTTPS and HTTP versions. I can browse to the file and when i click on it, it starts to download. But still getting the same error.


@member just in case, could you rename the file to osc.iso , adapt the profile and retry?


No luck. Still the same error.


Weird… Works on my side… every try… Ok, let’s gather a few infos then:

which UMS Version, Windows (target machine) version, is a AV / Proxy in use on server / endpoint side?


Using UMS 6.04.120. We use Crowdstrike on the server but it doesn’t block when we do firmware updates to IGEL devices. Im going to spin up a Win10 station in VM with no Antivirus on it and see if it still fails or works. I already had my Network guy check and he didnt see anything being blocked on his side.

One of my Managers was working on another project for IGEL. Getting custom Partition setup with Teams. He is running into the same problem. So its not a issue with AV on the desktop itself as he was trying this on a UD2 already running IGEL. SO i will be reaching out to my IT-SEC team and have them check our server. It just weird that we don’t have any issues doing Firmware updates from the IGEL Server.


@member on that last screenshot they have 8443 via https configured, but you have 9080 via http in your profile for the OSC. Do you know if you how your UMS server is configured to deliver files / firmware?


Can you check to use the full FQDN, no only the servername? I had the same problem with custom partition, it only works for me with FQDN or with IP-address


for firmware its the https and 8443. Forthe convertor i have tried both https/8443 and http/9080 and neither work. / Also tried FQDN earlier and doesnt work


Did you try applying a firmware update on the devices you are testing? Just to rule out some issue with network access to your test devices?


I just ran Firmware updates on a couple of new devices that came online yesterday and it did the update without issue. The Device my manager is trying to get the Teams partition setup on did a firmware up on it right before without issue. So we dont seem to have trouble with Firmware updates.


Actually the teams error shows a forward slash (/) on the end, this may indicate that the profile is not correctly configured


just another idea for the oscw download: can you please check if there special characters in the password like @ or # ?


Yes are password does have a @ in it.


Can you change it to a password without special character ? because the action will be startet like username@name@Password@pw@URL – if the identification is started in the middle of the password, the URL is wrong


Lars. Thank you that was it. My Win10 VM test machine started the download as soon as i updated the password in the profile. All that headache due to a @ sign in the password. Now i did run into a issue on the Win 7 Machine. Got the following error now. Error: 0x80072F7D; An error occurred in the secure channel support; igeladmin:*@10.125.10.80:8443/ums_filetransfer//osc11.03.560.iso.


I ran into the same issue with the IGEL/ControlUp custom partition. I had a “$” in my password.


OK after the download on my Win10 test machine. It says IGEL OSC Ready for Conversion. I then run the Special Device Command and Convert to IGEL. The task starts in UMS and then the Action failed due to Connection Timed Out: connect. I check my test machine and see igeloscinfo.exe is in process and using half the CPU. I have left the machine run for an hour. I’m i missing something here or is this really not something that works well over remote connections.

Just wanted to provide a update. I was able to get a Win10 PC to convert without issue. I found out from my IGEL rep is that the OS Convertor does not work in VM’s. So once i tested on a Win 10 PC it worked fine. The issue im running into now is on Win 7 PC’s. Im getting this error in UMS. Error: 0x80072F7D; An error occurred in the secure channel support; igeladmin:*@10.125.10.80:8443/ums_filetransfer//osc11.03.560.iso

Final update on this thread. So the error i got with Windows 7 was resolved by using the HTTP path instead of the HTTPS path. For some reason Win7 didn’t like the HTTPS path. Not sure if its just our PC’s and/or our environment. But HTTPS worked fine on Win 10. So i thought i share that info and thank everyone for their help.

Continue reading and comment on the thread ‘IGEL OS Creator for Windows – receive syntax error when assigning profiles to the target machine’.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base



Ask a question or comment on the above messasge thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!


Popular Message Threads


Categories & Tags: