IGEL OS devices boot to wrong time but when we click on the time it updates correctly?

Here’s another odd one: We set the date and time in a profile, and list our NTP servers. When some of the devices boot up, they show the wrong time. It’s not until you click on the time that it updates correctly. This is on 11.04.246.

Learn more, read the entire thread inside the IGEL Community o Slack

Could you check if the behavior happens too on .270? .246 was a bit tricky to handle.

Will do.

I know this is separate, but wouldn’t enabling persistent log storage in a profile also mean that when you save log files for support, it would grab those? I’m not seeing that work (all logs start after the last reboot).

It depends from how and from whom you get the Debug profile. Usually, the Debug profiles coming from our support would put the content into /debug

Which is a kind of persistent partition but not gathered by the USM from what I recall.

Hmm, all I did was check ‘Persistent log partition’ from here: kb.igel.com/igelos-11.04/en/logging-32871526.html

I basically just want to be able to look at older logs if a device is rebooted.

Then, I would go the route of Debug

I take it this isn’t something you guys recommend for Prod normally, enabling debuglog partition?

Also, FWIW, .270 didn’t solve that time issue. Hovering over the clock corrects it, but it’s still odd.

Hmm, second reboot and the time is correct.

I take it back, third reboot and it’s wrong until you hover over it, lol

Can you forward a screenrec and a screenshot of your NTP Profile? I just tried it here and it worked… Does it work if reset to factore and only assign NTP Profile?

I can give a factory reset a shot

Nope, same behavior. Time is wrong until you hover over the clock.

just for kicks have you tried a different NTP server??

Rushing to next call, but in addition to Georges idea, did you tried to set just one NTP? That’s how I have it and it works…

Yeah, tried different NTP servers. And yes, only had one NTP server listed initially, which is why I tried adding one (in the other was down).

I will say, I’m actually only seeing this on my QA IGEL VMs that are on my ESXi server. Physical UD2s seem fine.

Hem… Might it be that your Hypervisor tries to set the time too?

Something like that:

Time sync is disabled in ESXI.

Enabling it in ESXi does make it better. Just thought it was odd that IGEL wasn’t really refreshing the clock until I moved the cursor over it.

Continue reading and comment on the thread ‘IGEL OS devices boot to wrong time but when we click on the time it updates correctly? ‘.  Not a member? Join Here!

Learn more, search the IGEL Knowledge Base

Ask a question or comment on the above message thread?

Join or log in to the IGEL Community to ask us anything and meet other IGEL customers, partners, and EUC enthusiasts.

Submit a question, or Join Today!

Popular Message Threads

Categories & Tags: